cancel
Showing results for 
Search instead for 
Did you mean: 

Enabling GRE on TG582n router for incoming VPN

FIXED
Highlighted
mag21
Dabbler
Posts: 10
Thanks: 2
Registered: ‎29-01-2019

Enabling GRE on TG582n router for incoming VPN

Got the PlusNet standard Technicolor TG582n router (firmware 10.2.2.B) with a static external IP and am trying to set it up so that I can VPN from an external Win7 laptop into a Win10 desktop machine on the internal LAN, using PPTP for VPN.

Works fine if I borrow a friend's Draytek router and set up the port forwarding.

However it fails if I go back to the TG582n (just get Windows message saying can't connect), despite having used Games and App sharing to enable VPN PPTP - Shields Up website confirms that port 1723 is open.

Having read various forums, it seems that GRE also needs to be enabled for PPTP, and when I used the Telnet CLI interface to check out the current settings, it appears that GRE is 'disabled' by default.

Anyone know what the CLI command is to enable GRE, to see if that solves the VPN issue? Have to say that it is the first router I have come across which makes PPTP VPN difficult to set up.

(Yes, I do realise that I could go out and buy another brand of router for a quick fix, but a) given the CLI clearly shows 'disabled' for GRE, I would expect the CLI to provide a way to flip to 'enabled', and b) the router is conveniently small, and junking it would not be very eco-friendly... !)

Thanks

 

Tags (3)
8 REPLIES 8
Moderator
Moderator
Posts: 20,714
Thanks: 2,803
Fixes: 558
Registered: ‎11-01-2008

Re: Enabling GRE on TG582n router for incoming VPN


Moderators Note


This topic has been moved from ADSL Broadband to My Router.

Customer / Moderator
If it helped click the thumb
If it fixed it click 'This fixed my problem'
Superuser
Superuser
Posts: 7,395
Thanks: 1,271
Fixes: 80
Registered: ‎30-07-2007

Re: Enabling GRE on TG582n router for incoming VPN

Fix

@mag21  have a look at this thread https://community.plus.net/t5/ADSL-Broadband/Technicolor-TG582n-and-GRE/td-p/1040122

let us know if that doesnt fix it

Superuser
Superuser
Posts: 7,395
Thanks: 1,271
Fixes: 80
Registered: ‎30-07-2007

Re: Enabling GRE on TG582n router for incoming VPN

and you may also need to do this from the Telnet interface, take a look at this thread https://support.aa.net.uk/Router_-_TG582N_-_Firewall_and_Port_Forwarding

connection applist
connection unbind application PPTP port 1723
saveall
mag21
Dabbler
Posts: 10
Thanks: 2
Registered: ‎29-01-2019

Re: Enabling GRE on TG582n router for incoming VPN

That's really great - thanks for taking the time to post.

Shall try that out this evening and report back.

 

mag21
Dabbler
Posts: 10
Thanks: 2
Registered: ‎29-01-2019

Re: Enabling GRE on TG582n router for incoming VPN

Was briefly at the site where I'm setting this up and did both, but did not seem to work... (i.e. same failure of VPN to get PPTP connection with PC on internal LAN behind router)

... however that could well be down to me having thrashed around earlier with various desperate settings on the router, so shall hang on till weekend when I am there again and do a full reset on the router, they carefully work through settings.

Shall let you know how it goes, thanks again.

 

mag21
Dabbler
Posts: 10
Thanks: 2
Registered: ‎29-01-2019

Re: Enabling GRE on TG582n router for incoming VPN

(Not seeing 'this fixed it option' - but it did)

Hi MisterW, thanks - have now managed to test and your referred solution worked fine - I can now VPN in through the TG582n router to a Windows 7 Pro box without any issues.

To summarise for the next person with this issue (my firmware was 10.2.2.B):

- maybe best to reset router (if you have been fiddling to sort this) - press reset pinhole button on rear of router for 7 secs+ or until light(s) go off and then on

- wait for your connected device to get IP address from DHCP on the router - can take a couple of minutes

- Telnet into the router using CMD [see thread re making sure Telnet is on your device]. In my case, with reset router, the telnet command is: open 192.168.1.254

- Check that your existing TG582n firmware even supports GRE - run this telnet command: service system list  [you should see GRE mentioned towards top, albeit marked as 'disabled'.  If you don't see GRE mentioned, then you need to update your firmware. Good luck with that... Google to find possible method]

- Use telnet to enable GRE: service system list modify name=GRE state=enabled

- Then make the change permanent with the telnet command: saveall [takes 30 secs]

Exit out of Telnet and the CMD window, then log into the router using the GUI, in order to set it up for PPTP for the VPN (unless already done).

- Go to Home Network, Devices and click the task 'Assign a game or application to a local network device', click on Local Internet

- click on the drop down for Game/Application (usually starts with AIM Talk) and choose PPTP, then select the device (pc/laptop) you want to VPN into, and then 'Add'. Ditto if you want to set up Microsoft Remote Desktop

- note that obviously the device (say, a Windows 7 PC) needs to have been set up as a VPN server. Ditto Remote Desktop.

 

Just to be on safe side, I also rebooted the Router after all this - have to say that the Technicolor manual is not easy to follow - no mention of the existence of 'saveall' for example! But since the TG582n is now superseded, guess that is ancient history.

 

Thanks again.

 

 

mag21
Dabbler
Posts: 10
Thanks: 2
Registered: ‎29-01-2019

Re: Enabling GRE on TG582n router for incoming VPN

Sorry should have clarified that I did not need to do the extra Unbind stuff.

Superuser
Superuser
Posts: 7,395
Thanks: 1,271
Fixes: 80
Registered: ‎30-07-2007

Re: Enabling GRE on TG582n router for incoming VPN

@mag21  thanks for the feedback