cancel
Showing results for 
Search instead for 
Did you mean: 

DNS Issues

FIXED
Highlighted
Grafter
Posts: 26
Thanks: 7
Registered: ‎22-06-2020

Re: DNS Issues

Well, its been a while, but it has finally failed again. Sad 

Highlighted
Community Gaffer
Community Gaffer
Posts: 14,633
Thanks: 2,225
Fixes: 153
Registered: ‎04-04-2007

Re: DNS Issues

@IanSudbery completely missed this. I'm guessing it's not still in the failed state and has since been rebooted?

Plusnet Hub One> net host bbc.co.uk
Found host bbc.co.uk:
151.101.0.81
151.101.64.81
151.101.128.81
151.101.192.81

 

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

Highlighted
Grafter
Posts: 26
Thanks: 7
Registered: ‎22-06-2020

Re: DNS Issues

@bobpullen Yeah, our circuit breaker tripped and the router lost power. 

Highlighted
Grafter
Posts: 26
Thanks: 7
Registered: ‎22-06-2020

Re: DNS Issues

@bobpullen Its gone down again!

Highlighted
Community Gaffer
Community Gaffer
Posts: 14,633
Thanks: 2,225
Fixes: 153
Registered: ‎04-04-2007

Re: DNS Issues

Excellent! (from a diagnostic positioning of course) 😉

I think this safely rules out anything your side of the router...

Plusnet Hub One> net host bbc.co.uk
Gethostbyname failed

Any chance you can leave it broken for the afternoon?

I'd like to see what else we can determine whilst it's in this state. 

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

Highlighted
Community Gaffer
Community Gaffer
Posts: 14,633
Thanks: 2,225
Fixes: 153
Registered: ‎04-04-2007

Re: DNS Issues

@IanSudbery, if you're still keeping tabs on things, would you be able to try generating some traffic on your local network where a device is trying (and failing) to use the hub again for DNS?

We've some logging running and it would be good to get some 'real-life' events captured.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

Highlighted
Grafter
Posts: 26
Thanks: 7
Registered: ‎22-06-2020

Re: DNS Issues

Will do, sorry, I've been out this afternoon. 

Highlighted
Community Gaffer
Community Gaffer
Posts: 14,633
Thanks: 2,225
Fixes: 153
Registered: ‎04-04-2007

Re: DNS Issues

@IanSudbery, pleased to say we managed to get some very useful diagnosis from your hub so thankyou!

We've identified what we believe to be the problem and the team are exploring options.

In the meantime, I have an update that I would like to try pushing to your hub if you are willing? It doesn't fix the issue entirely, but it should help mitigate against the problem. From what I've seen it shoud do a good job of improving response times to/from your router too.

Let me know if you're interested.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

Highlighted
Grafter
Posts: 26
Thanks: 7
Registered: ‎22-06-2020

Re: DNS Issues

Hi @bobpullen , Sorry fot the delay. we'd be happy for you to push an update.

I'm not networking expert, but I do work in a computer science adjacent field. Perhaps you wouldn't mind letting me know what was causing the problem? 

Highlighted
Community Gaffer
Community Gaffer
Posts: 14,633
Thanks: 2,225
Fixes: 153
Registered: ‎04-04-2007

Re: DNS Issues

@IanSudbery thanks, was asked to hold on a week longer but that's now been done for you.

You'll need to reboot the hub, after which you should find you're running a software version ending .284.

Keep an eye on things and let me know if the error condition returns. As mentioned previously, this build doesn't fully fix the issue (assuming we've nailed the cause), however it should make it less likely to manifest itself.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

Highlighted
Community Gaffer
Community Gaffer
Posts: 14,633
Thanks: 2,225
Fixes: 153
Registered: ‎04-04-2007

Re: DNS Issues

@IanSudbery how have things been of late?

In way of an update, we've had a bit of a breakthrough on this one and we think we now know what is giving rise to the condition. We're just working through details of the fix.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

Highlighted
Grafter
Posts: 26
Thanks: 7
Registered: ‎22-06-2020

Re: DNS Issues

Was about to say it was all going well, and then it happened again today. However, that was the first time in ages that it had happened. 

Highlighted
Grafter
Posts: 26
Thanks: 7
Registered: ‎22-06-2020

Re: DNS Issues

In fact, its not happened twice in one day. 

Highlighted
Community Gaffer
Community Gaffer
Posts: 14,633
Thanks: 2,225
Fixes: 153
Registered: ‎04-04-2007

Re: DNS Issues

I'll give you a nudge shortly when I've a full fix available. It would be really helpful for you to help test it if you'd be willing?

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

Highlighted
Community Gaffer
Community Gaffer
Posts: 14,633
Thanks: 2,225
Fixes: 153
Registered: ‎04-04-2007

Re: DNS Issues

@IanSudbery - is the hub in a failure state again? I have the fix ready to go but I'm struggling to communicate with it. Any chance you can reboot it when it's next convenient?

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵