cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco Expert needed 887VA plusnt fibre

andydis
Newbie
Posts: 2
Registered: 16-01-2014

Cisco Expert needed 887VA plusnt fibre

Hello,

 

So i wanted to setup a 887va router i had spare (to setup a site to site VPN connection for work)

i can get it connected so the VDSL LIGHT is on and the data light flashes, it even gives the correct external static ip address.
But i cannot access the internet , config below, i would be very grateful!

 

 

 

2 REPLIES
mikelahey
Aspiring Pro
Posts: 166
Thanks: 63
Fixes: 10
Registered: 24-11-2015

Re: Cisco Expert needed 887VA plusnt fibre

Try this config, I think it will work. You need to change the *YourUsername* and *YourPassword* to yours.

Connect the phone line to the router using the RJ11 and Ethernet3 to your network.

 

Try this:


i
ip cef
no ipv6 cef
!
username *-* privilege 15 password 0 *-*
!
controller VDSL 0
no cdp run
!
interface Ethernet0
no ip address
ip virtual-reassembly in
no ip route-cache
!
interface Ethernet0.101
description Tagging for PPPoE (VDSL 0)
encapsulation dot1Q 101
ip nat outside
ip virtual-reassembly in
no ip route-cache
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
no ip address

shutdown
no cdp enable
!
interface FastEthernet1
no ip address
shutdown
no cdp enable
!
interface FastEthernet2
no ip address
shutdown
no cdp enable
!
interface FastEthernet3
no ip address
no cdp enable
!
interface Vlan1
ip address 10.80.2.252 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat inside
ip virtual-reassembly in
ip route-cache policy
!
interface Dialer1
description **Plus Net**
ip address negotiated
ip access-group 101 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
ip nbar protocol-discovery
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication pap chap ms-chap callin
ppp chap hostname *YourUsername*@plusdsl.net
ppp chap password 0 *YourPassword*
ppp ipcp dns request accept
ppp ipcp route default
ppp ipcp address accept
no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http authentication local
no ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
access-list 1 permit any
!
control-plane
!
line con 0
no modem enable
line aux 0
line vty 0 4
privilege level 15
password *YourPassword*
login local
transport input telnet ssh
!
end

 

mikelahey
Aspiring Pro
Posts: 166
Thanks: 63
Fixes: 10
Registered: 24-11-2015

Re: Cisco Expert needed 887VA plusnt fibre

I didn't have much time this morning, so I just posted a full config so that you could compare yours with the one I posted.

First you need to get rid of interface dialer0 as you are using dialer1 for VDSL. You've shut down the atm0 interface which is for ADSL so that looks right.

The Vlan 101 sub interface on Ethernet0 (Which is the VDSL modem) needs a little bit more config to make it work.

You need to add: ip nat outside  to tell the router that its WAN side, also add the following:

ip virtual-reassembly in
no ip route-cache
pppoe enable group global

 

Vlan1 is the default Vlan for the Ethernet switch built into the router and this looks OK.

 

Also on dialer1 I think the MTU sizes are incorrect:

 

ip tcp adjust-mss 1452

ip mtu 1492