cancel
Showing results for 
Search instead for 
Did you mean: 

Apple iMac hangs when connected to Plusnet router

alisonleach11
Newbie
Posts: 4
Registered: Sunday

Apple iMac hangs when connected to Plusnet router

Hi,,

 

We have just swapped to Plusnet and cannot connect to internet either via wireless or ethernet to the new router to our Apple iMac. All other devices including an iPhone 6 connect fine. Before this we were with Sky and BT before then. We have never had this problem before. I notice on these boards that Macs have had problems in the past  for Plusnet and one fix was to

 

"go into the Hub One web interface and split the 2.4ghx and 5ghz wireless networks into 2"

 

However, I can't see these options any more?

 

I have contacted Plusnet tech and been told to get in touch with Apple.

 

Thanks for any advice in advance.

8 REPLIES
LifeonMars
Aspiring Pro
Posts: 158
Thanks: 45
Fixes: 4
Registered: 07-04-2016

Re: Apple iMac hangs when connected to Plusnet router

alisonleach11
Newbie
Posts: 4
Registered: Sunday

Re: Apple iMac hangs when connected to Plusnet router

Thanks for your quick response. I really appreciate it.

 

I am not very techy and  I can't see any of these options when I go into the interface.  I can't find an option for Wireless on any of the tabs?

 

I do have a tab for Advanced Settings and then  a WiFi option. I don't see any of the options you suggest I amend on this  tab?  Is it the channel number I change? ie from auto to 5? And the only box I have which has SSID in is Broadcast SSID. Is this the box I uncheck?

 

If you can point me in the right direction, that would be great!

LifeonMars
Aspiring Pro
Posts: 158
Thanks: 45
Fixes: 4
Registered: 07-04-2016

Re: Apple iMac hangs when connected to Plusnet router

Look at the you tube link in previous post
This should show what you have to do if you have the hub one
I do not use a hub one but prefer the BT Smart hub.
However click on Advanced settings as the video instructs.
Alter the names of 5GHZ band by adding a 5 or what you wish,
You must go into the 2.4GHZ tab on wireless settings and uncheck sync with 5GHZ
alisonleach11
Newbie
Posts: 4
Registered: Sunday

Re: Apple iMac hangs when connected to Plusnet router

Thanks again. I don't have a Hub One. It looks like I have been given an older version which is why I can't see these settings. The plusnet Youtube video refers to the Hub One.  I have searched for YouTube videos for my hub with no success. I can't see any way of amending these options in the interface I have so I guess I will have to contact the technical helpline again.

 

Appreciate your help LifeonMars

alisonleach11
Newbie
Posts: 4
Registered: Sunday

Re: Apple iMac hangs when connected to Plusnet router

Further investigations show that I only have 2.4GHZ option on this older hub - that's why I can't find the options to change the wireless settings... Hmmm not very pleased that I have been given old hardware.

 

 

LifeonMars
Aspiring Pro
Posts: 158
Thanks: 45
Fixes: 4
Registered: 07-04-2016

Re: Apple iMac hangs when connected to Plusnet router

I am surprised you have an older router, as you have just joined Plusnet. If you have a BT Hub 5 or BT Smart Hub (6) these also work with Plusnet and dual band see
https://community.plus.net/t5/Broadband/BT-Home-Hub-6-Smart-Hub-on-PlusNet/m-p/1415464#M312705
Baldrick1
Seasoned Champion
Posts: 1,415
Thanks: 613
Fixes: 49
Registered: 30-06-2016

Re: Apple iMac hangs when connected to Plusnet router

Unfortunately ADSL customers only get a Hub Zero rather than a Hub One. Nevertheless if you get slow speeds with an Ethernet cable, messing with wireless settings will not help. If you were previously with BT and still have a BT router then try that. You will find the simple instructions required to use it on your Plusnet account in this forum.

Plusnet Help Team
Plusnet Help Team
Posts: 8,294
Thanks: 2,506
Fixes: 412
Registered: 21-04-2017

Re: Apple iMac hangs when connected to Plusnet router

Hi there.

I'm sorry to hear you're having problems using your iMac with your Hub Zero router.

Do you mind me asking what version of OS your iMac is running? If your Mac essentially crashes when connecting to the router, this issue seems to affect Macs running the OS Snow Leopard or older, and the fix is to turn IPv6 off in your iMac settings. Steps to do this can be found Here

That said I can see we're sending you a Hub One. Let us know how it goes when you receive it. I'd also still be interested to know if the above fix works for you too in the meantime.

I hope this helps.

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team