cancel
Showing results for 
Search instead for 
Did you mean: 

Android App cannot access internet after router reboot

FIXED
fatbellybinky
Dabbler
Posts: 18
Thanks: 6
Fixes: 1
Registered: ‎09-10-2017

Android App cannot access internet after router reboot

This is a bit of odd issue that seems to be router related so posting here as a starting point.  I have an Android App for checking lottery syndicate numbers that I run on my phone and tablet. A few months ago it suddenly stopped being able to access the internet to retrieve the lottery numbers but could still pop up in-app adverts!  It would work over mobile data on my phone and also over my daughter's Sky router WiFi  but not on my Plusnet WiFi or my son's Plusnet WiFi. Everything else on my home network is working fine so it's just this one App that has a problem and only on my home network.

I contacted Plusnet and although they didn't suggest anything for a fix, it magically started working again a day later so I thought they must have tweaked something. 

The App has been working fine until about a month ago when it started failing again - same symptoms BUT this time, I found that it will work on my spare Android mobile phone over my Plusnet WiFi, but not my main phone or tablet (both Android but different versions). I tried a router re-boot and that seemed to get it going again but this weekend we had a power outage and you guessed it - the App can't access the lottery results again except on that one Android phone. It will however still work OK on my son's Plusnet WiFi using my main phone and Tablet so it would suggest an issue with my own router but doesn't explain why the app still works on one mobile phone connected to my router. 

The App developer can't understand what the problem could be and the URL which the App goes to to retrieve the lottery results can be accessed using a browser an all my devices over my WiFi.  I don't have Plusnet Safeguard enabled so it's not blocking access to the lottery web site. 

My router is a Hub One with firmware reported as follows:-

 Plusnet Hub One | Software version 4.7.5.1.83.8.237.2.2 | Last updated 14/08/17

It looks like it's never updated itself to the later 2018 level that's on my son's router. I'm wondering if an update might fix this weird issue but can't update it manually myself and am reluctant to risk introducing other issues because everything else works fine.

Just wondered if anyone has seen anything like this and could offer any suggestions short of trying to request a router firmware update? 

4 REPLIES 4
adamwalker
Plusnet Help Team
Plusnet Help Team
Posts: 15,184
Thanks: 462
Fixes: 126
Registered: ‎27-04-2007

Re: Android App cannot access internet after router reboot

Hi fatbellybinky,

 

It might be worth trying a factory reset of the Hub One if you haven't already: https://www.plus.net/help/broadband/router-user-guides/

 

If that doesn't change anything we can certainly try pushing a firmware update. 

 

 

If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team
bobpullen
Community Gaffer
Community Gaffer
Posts: 14,832
Thanks: 2,423
Fixes: 163
Registered: ‎04-04-2007

Re: Android App cannot access internet after router reboot

@fatbellybinky, I've pushed the latest firmware to your router, but judging by your description, I'm not convinced it's going to do much.

The problem smells a little like one I helped deal with a while ago, but it was far from straightforward to troubleshoot, and required a lot of co-operation from the developer of the site/service in question.

One workaround for that particular issue was to try enabling our Safeguard service, reboot the router, wait an hour or so, disable the service and then reboot again.

Worth a try maybe?

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

fatbellybinky
Dabbler
Posts: 18
Thanks: 6
Fixes: 1
Registered: ‎09-10-2017

Re: Android App cannot access internet after router reboot

Hi Bob. Yes, I saw the firmware update get pushed to my router as I was online at the time when it re-booted 🙂  Sadly it hasn't fixed the problem though but at least it hasn't broken anything. I'll try your suggestion to enable/disable Safeguard and see if it has any effect. Watch this space !!!  

fatbellybinky
Dabbler
Posts: 18
Thanks: 6
Fixes: 1
Registered: ‎09-10-2017

Re: Android App cannot access internet after router reboot

Fix

@fatbellybinky wrote:

Hi Bob. Yes, I saw the firmware update get pushed to my router as I was online at the time when it re-booted 🙂  Sadly it hasn't fixed the problem though but at least it hasn't broken anything. I'll try your suggestion to enable/disable Safeguard and see if it has any effect. Watch this space !!!  


Bob, 

Looks like my issue has now been resolved although not before a few weird problems. The initial firmware update and reboot didn't seem to fix anything so I rebooted again and this time the App worked OK on my tablet and Samsung phone but stopped working on the spare phone where it had previously worked OK. I also discovered that my security floodlight/camera would no longer connect to my router which was a more serious concern. Tried another reboot using the reset button on the router rather than logging in to it but still no security camera. This morning I decided to power cycle the router rather than just rebooting it and now everything works fine.   My camera is back online and the lottery App works on all my three Android devices.  Difficult to know if it really was the firmware update or the power cycling that fixed it but since it was power cycled over the weekend due to a supply outage I'm hoping that the new firmware was the solution. Only time will tell 🙂

Thanks for your help.