cancel
Showing results for 
Search instead for 
Did you mean: 

Still no broadband activation after 5 days

Paddyrat
Dabbler
Posts: 13
Registered: ‎28-02-2022

Still no broadband activation after 5 days

Well what can an I say?.
Anyone reading this, and all the other complaints regarding plusnets complete inability to offer any kind of good service, take heed!
I have waited five days to be activated, everyday I have called them, everyday I am told the problem is with open reach.
Everyday I am assured that I will get a call back to update me. NOTHING.
I spend on average an hour everyday talking to plusnet.
They tell me how sorry they are but it's in the hands of openreach.
Today I'm told to wait 48 hours for OR to respond.
TO ANYONE CONSIDERING PLUSNET, AS I DID, I WOULD THINK AGAIN.
DONT BE FOOLED BY THE 'CHEEKY CHAPPY' ON THEIR ADVERTS......The service is a disgrace and no better than any other provider.....the one saving grace is that you don't have to pay to call them...but the same old excuses prevail....the blame games with openreach.
I wish I had stayed with Talktalk although it greaves me to say that.
Plusnet.....your not 'Doing me proud'....and NO 'It won't do!!!!!
29 REPLIES 29
Baldrick1
Moderator
Moderator
Posts: 11,706
Thanks: 5,204
Fixes: 418
Registered: ‎30-06-2016

Re: Still no broadband activation after 5 days


@Paddyrat wrote:
..but the same old excuses prevail....the blame games with openreach.

Both are to blame.

Openreach for not providing the service. They are a law unto themselves over which Plusnet have no control and very little influence.

Plusnet in failure to communicate with customers and possibly chasing Openreach.

The problem as i see it is that both Plusnet and Openreach are BT owned organisations. Corporate niceties forbid Plusnet to publicly criticise or take any serious action against their so called 'suppliers'.

Moderator and Customer
If this helped - select the Thumb
If it fixed it,  help others - select 'This Fixed My Problem'

Paddyrat
Dabbler
Posts: 13
Registered: ‎28-02-2022

Re: Still no broadband activation after 5 days

Nearly 48 hours.....nothing has been heard from plusnet......
Gandalf
Community Gaffer
Community Gaffer
Posts: 26,574
Thanks: 10,294
Fixes: 1,600
Registered: ‎21-04-2017

Re: Still no broadband activation after 5 days

Hi @Paddyrat

I'm really sorry for the delay with your order.

Having looked into this, I can see the transfer of your line came across to us as planned on the 23rd February, but something went wrong with your broadband order, which meant our broadband didn't activate the same day. 

The latest notes on your account suggest we've got in touch with our suppliers helpdesk and they've said an engineer should be going out tomorrow, but as this is the 3rd date we've been given, I've raised an escalation with our suppliers.

As soon as I've got a response which should be tomorrow now due to the time of night, I'll let you know. 

From 31st October 2022, I no longer have a regular presence here as I’ve moved on to a new role.
Anoush Mortazavi
Plusnet
Paddyrat
Dabbler
Posts: 13
Registered: ‎28-02-2022

Re: Still no broadband activation after 5 days

48 hours and still no contact from Plusnet.
Great service your providing guys
Anoush
Aspiring Hero
Posts: 2,568
Thanks: 572
Fixes: 139
Registered: ‎22-08-2015

Re: Still no broadband activation after 5 days

I’m from Plusnet and I’ve made contact tonight, but due to the time I won’t have a response on the escalation until tomorrow and once I do, I will be back in touch.

This is my personal Community Forum account to help out around these parts while I'm at home. If I'm posting from the 1st March 2020, this means I'm off-duty with no access to internal systems.
If this post resolved your issue, please click the 'This fixed my problem' button
Gandalf
Community Gaffer
Community Gaffer
Posts: 26,574
Thanks: 10,294
Fixes: 1,600
Registered: ‎21-04-2017

Re: Still no broadband activation after 5 days

Hi there,

Just to update. I've not received a response from our suppliers escalation team quite yet but I should do today.

Once I know more I'll be sure to let you know

From 31st October 2022, I no longer have a regular presence here as I’ve moved on to a new role.
Anoush Mortazavi
Plusnet
Paddyrat
Dabbler
Posts: 13
Registered: ‎28-02-2022

Re: Still no broadband activation after 5 days

Day 7 of no Internet.
Just another apology saying its awaiting open reach and to wait up to another 48 hours!
Absolutely fed up with plusnet!!!!
Gandalf
Community Gaffer
Community Gaffer
Posts: 26,574
Thanks: 10,294
Fixes: 1,600
Registered: ‎21-04-2017

Re: Still no broadband activation after 5 days

@Paddyrat

I understand the frustration and we're doing what we can to activate your service as soon as possible.

Let me chase this up with our suppliers now and I'll post back once I know more. 

From 31st October 2022, I no longer have a regular presence here as I’ve moved on to a new role.
Anoush Mortazavi
Plusnet
Gandalf
Community Gaffer
Community Gaffer
Posts: 26,574
Thanks: 10,294
Fixes: 1,600
Registered: ‎21-04-2017

Re: Still no broadband activation after 5 days

Hi @Paddyrat

Our suppliers escalation team have advised me that the necessary engineering work to get you online should already be carried out, so we'd just need the order completing in the supplier systems for the service to be configured & activated.

I've got in touch with our suppliers helpdesk just now and I've discussed this with a team supervisor, who has advised that the remaining work is what's known as "jumper recovery" which is non-service affecting work for an engineer to disconnect the previous provider's equipment at the exchange.

As this work is non-service affecting, the supervisor has tested your line and as the tests have passed, they've manually triggered the order to complete, which should happen before midnight tonight.

I'll be checking this again for you tomorrow morning when I'm in the office from 11:30am.

From 31st October 2022, I no longer have a regular presence here as I’ve moved on to a new role.
Anoush Mortazavi
Plusnet
Paddyrat
Dabbler
Posts: 13
Registered: ‎28-02-2022

Re: Still no broadband activation after 5 days

You will have to forgive me for not feeling at all optimistic.
I have been here several times with the 'activated before midnight ' line.
I will be very happy if it is done by 12 but I have my doubts....
Gandalf
Community Gaffer
Community Gaffer
Posts: 26,574
Thanks: 10,294
Fixes: 1,600
Registered: ‎21-04-2017

Re: Still no broadband activation after 5 days

Thanks for getting back to me @Paddyrat

I can absolutely understand that as we've given multiple promised dates as we share the frustration too. 

If the order's not completed tonight, I'll be chasing this up with our suppliers again tomorrow for you. 

From 31st October 2022, I no longer have a regular presence here as I’ve moved on to a new role.
Anoush Mortazavi
Plusnet
Paddyrat
Dabbler
Posts: 13
Registered: ‎28-02-2022

Re: Still no broadband activation after 5 days

Well yesterday evening i got a text saying that I was now able to connect to the broadband.....as well as your reply on this platform saying all was good to go.
I have turned the modem on this morning...DAY 8!!!!!!......and surprise surprise....still cannot connect to the broadband after 8 DAYS!!
So plusnet I hope you can see that in spite of your messaging yesterday...I was right to feel pessimistic about you actually sorting this mess out.
I am today messaging my local MP and will also be contacting citizens advice to ask exactly where I stand with regards to your lies and exactly what my rights are having been left with no Internet for 8 days.
The empty apologies you keep telling are now falling on very deaf ears.
Plusnet you are disgrace
jab1
Legend
Posts: 17,095
Thanks: 5,482
Fixes: 255
Registered: ‎24-02-2012

Re: Still no broadband activation after 5 days

@Paddyrat How far in your attempts to connect do you get, and what Hub do you have? What lights (if any) are showing?

John
Paddyrat
Dabbler
Posts: 13
Registered: ‎28-02-2022

Re: Still no broadband activation after 5 days

Plugged in the router.
After 5 mins shows the flashing red broadband light and the power light is orange.
I have a sagemcom plusnet hub one