cancel
Showing results for 
Search instead for 
Did you mean: 

FTTC Problem

sejones968
Newbie
Posts: 1
Registered: ‎22-11-2020

FTTC Problem

After nearly a month of being messed around with BT I decided to switch to Plusnet in an effort to establish a decent internet connection.

I originally placed an order in Oct with Plusnet and was told a few days after that my order had been cancelled as fibre is not available, when I rang to formally cancel the order, the very kind operator on the phone told me that it was a computer system error, he again reassured me that I can most certainly have FTTC and then manually replaced the order.

I've waited 10 days for the switch and now I've been told only after ringing a day after I was supposed to go live that FTTC isn't available because the cabinet is "at capacity" however, through separate correspondence through to Openreach and other checks done through BT wholesale have also confirmed that fibre is available.

 

I can't help but feel Plusnet are not making sufficient efforts to resolve this with Openreach. This is now the second time I've been told FTTC isn't available when it clearly is and I feel like this is more of an effort from phone operators to get through as many phone calls as possible rather than fully investigating what the problem might be.

Both me and my partner work from home and fundamentally rely on an internet connection. This level of customer service just isn't acceptable!

 

2 REPLIES 2
dvorak
Moderator
Moderator
Posts: 25,878
Thanks: 4,879
Fixes: 1,236
Registered: ‎11-01-2008

Re: FTTC Problem


Moderators Note


This topic has been moved from Fibre to My Order 

Customer / Moderator
If it helped click the thumb
If it fixed it click 'This fixed my problem'
Baldrick1
Seasoned Hero
Posts: 6,734
Thanks: 3,021
Fixes: 203
Registered: ‎30-06-2016

Re: FTTC Problem

@sejones968 

Be aware that both BT  retail and Plusnet use the Openreach network and any network problems have to be fixed by them. Moving from BT's premier service (BT Retail) to BT's budget ISP (Plusnet) is not likely to result in any priority sevice from Openreach.

Covid is currently causing havok with the level of Plusnet customer services.