cancel
Showing results for 
Search instead for 
Did you mean: 

Activation date was 5 days ago and still no router

kirstybarnes15
Newbie
Posts: 4
Thanks: 1
Registered: ‎03-12-2021

Activation date was 5 days ago and still no router

My email from plusnet said my activation was 5th December. Nothing came. I used the forum and was told that my activation had changed to 10th (no plusnet customer service communication at all on this matter!)
So my activation is 10th, great. My broadband was switched off on the 10th but I STILL have no router. I received the text to say it was on the way on the 7th but it is now the 15th December I have been without internet for 5 days since switch off on the 10th and I am appalled at the terrible customer service and communication. I need my router to work the fibre that I am paying an increased amount for; a service that I upgraded because of your pitiful broadband speeds with standard broadband. My area is not impacted by Royal Mail issues as I have received standard post in the days since.
1 REPLY 1
Gandalf
Community Gaffer
Community Gaffer
Posts: 25,912
Thanks: 9,535
Fixes: 1,512
Registered: ‎21-04-2017

Re: Activation date was 5 days ago and still no router

Thanks for your post @kirstybarnes15

I'm really sorry to see you haven't received your new router yet.

From what I can see we've put it in the post on the 8th December, so I suspect it's been lost somewhere. Upon further investigation, we've got some missing details of your address in your account so this may likely be the cause. 

I've updated your address now and I've sent a new router we'll get to you as soon as possibly can.

I can also see you've raised a complaint, so someone from our complaints team will be getting in touch with you shortly. 

If this post resolved your issue please click the 'This fixed my problem' button.
From 31st October 2022, I no longer have a regular presence here as I've moved on to a new role within Plusnet.

 Anoush Mortazavi
 Plusnet