cancel
Showing results for 
Search instead for 
Did you mean: 

paid for LRS or have I?

squawk7000
Dabbler
Posts: 13
Thanks: 1
Registered: ‎08-05-2009

paid for LRS or have I?

last week I logged in and renew my Line Rental Saver (LRS) using my debit card

I received a confirmation email saying that I have paid

There is a line on the payments screen that says I have paid

There is an item in the closed questions saying that I have paid (388613214)

Payment appeared on my online bank statement as a pending item, then after a week disappeared.

so I have emails etc that I have renewed my LRS, but you haven't taken the money.

 

Have I renewed my LRS? or do I have to try to pay it again?

 

3 REPLIES 3
Plusnet Help Team
Plusnet Help Team
Posts: 599
Thanks: 106
Fixes: 31
Registered: ‎06-08-2018

Re: paid for LRS or have I?

Hello @squawk7000

 

Thank you for your post. I have looked into your account and responded to your query with a detailed email.

 

You can view this on your members portal by Clicking Here

 

Should you need any further assistance, feel free to ask.

If this post resolved your issue please click the 'This fixed my problem' button
 Wakas Hussain
 Plusnet Help Team
squawk7000
Dabbler
Posts: 13
Thanks: 1
Registered: ‎08-05-2009

Re: paid for LRS or have I?

Thank you for your reply. I see that Plusnet think that I have paid. I have spoken to my bank and they confirm that the payment was not actually taken. They can see that it went into the pending payments list but dropped off after 7 days because the funds weren't requested by Plusnet.

 

I suppose all I can do is wait, and leave enough in my bank account to cover it once you realise you haven't actually got my money. Just don't set the debt collectors onto me.

 

All very curious

Plusnet Help Team
Plusnet Help Team
Posts: 1,402
Thanks: 276
Fixes: 80
Registered: ‎26-03-2018

Re: paid for LRS or have I?

Hi @squawk7000,

 

Thank you for letting us know what your bank have said about how the payment is looking from their side. This is an unusual issue, as it's showing from our side that the LRS payment has been taken successfully.

 

I've raised a ticket to our billing team so that they can have a look into what's happened here and contact you to attempt to take the LRS payment if need be. I have also asked them to ensure that no restrictions go onto your account (though it's unlikely that this would happen anyway.) You should hear back from this team within 5-10 working days. Sorry for any inconvenience that this has caused.

If this post resolved your issue please click the 'This fixed my problem' button
 Emily D
 Plusnet Help Team