Showing results for 
Search instead for 
Did you mean: 

Unable to access account

Posts: 5
Registered: ‎27-02-2017

Unable to access account

I'm unable to access both my centre and also webmail account. Plusnet has completely messed up my account. I have tried repeatably to reset password but when i enter my login it states no account found. I have spoken to support and the reset password online, but i was unable to access from my computer. They tried to tell me it was a problem with my iMac  but i have tried on all mac computers 3 off and also iPad and windows computer. the problem exists with al of them. trying again to get through to support, its a joke. when i first got plusher in all worked fine and then suddenly its all gone [-Censored-] up. hope someone can help.

Plusnet Help Team
Plusnet Help Team
Posts: 22,211
Thanks: 7,641
Fixes: 1,290
Registered: ‎21-04-2017

Re: Unable to access account

Hi there.


Sorry for the problems you're having.

From reading the notes on your account, I understand this is now resolved and you're able to login?

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team