cancel
Showing results for 
Search instead for 
Did you mean: 

No Payment Taken Since March!

FIXED
Muppzlab
Hooked
Posts: 5
Registered: ‎03-09-2019

No Payment Taken Since March!

Hello Plusnet,

I contacted customer support yesterday about not being able to activate Plusnet Protection and was informed it was due to the billing system being down. I was then told it had been so since March and that matches the last payment taken on my bank statement. Now I find I can't create a mailbox or an alias, is this also down to the billing issue?

I was told it was not possible to do a manual work around for the Plusnet Protection (you can't give me a download link?), how ridiculous for a company that boasts how good it's customer service is. I am 'nominally' paying for a service, we have a contract and you are failing to deliver on it because you haven't been able to fix a billing system in 6 months. 

The statement in another thread (No Payment Taken August 2019) stating that this will not affect service is obviously erroneous in my experience.

Kindly either give me a work around or an ETA for when this will be resolved.

Thanks,

Chris

9 REPLIES 9
MasterOfReality
Plusnet Help Team
Plusnet Help Team
Posts: 1,640
Thanks: 275
Fixes: 57
Registered: ‎26-03-2018

Re: No Payment Taken Since March!

Hi @Muppzlab 

 

Thanks for getting in touch. 

 

The issues mentioned to you should not affect you creating an alias or mailbox - can you tell us what happens when you try this? 

 

In regards to a workaround for Plusnet Protect, I'm afraid we don't have a download link et al. When it comes to an ETA, we are continually working on issues and as soon as we have more information, we will update customers accordingly. We are able to say that once your billing profile is rectified, we will only be applying for the last 90 days worth of service. 

 

Kind Regards, 

MoR

If this post resolved your issue please click the 'This fixed my problem' button
 MoR
 Plusnet Help Team
Muppzlab
Hooked
Posts: 5
Registered: ‎03-09-2019

Re: No Payment Taken Since March!

Hi MoR,

Thanks for your reply.

 

When attempting to create, an alias or mailbox the process seems to complete without error and it says changes will take 30 minutes. However even days later nothing has appeared.

 

On the Plusnet Protect, I don't think saying what effectively boils down to 'well we aren't charging you for it' is really the solution I was hoping for Sad

 

Regards,

 

Chris

Optimatts
Plusnet Alumni (retired)
Plusnet Alumni (retired)
Posts: 442
Fixes: 19
Registered: ‎25-09-2018

Re: No Payment Taken Since March!

Hi @Muppzlab,

 

You should still be able to create mailboxes and aliases. I've just checked your account and while I can't confirm any account specifics, we're seeing there are some aliases and mailboxes set up on your account.

 

Can you confirm if you've created them previously and it's not letting you create new ones.... or is this the first time you've tried setting them up?

 

In addition, are you using a client to receive your emails? If so, have you checked to see if they are active and working in webmail?

 

 

Muppzlab
Hooked
Posts: 5
Registered: ‎03-09-2019

Re: No Payment Taken Since March!

Hi Optimatts,

 

I have previously created mailboxes and alias but that was a few years ago.

Yes I use a client and I get the following error when trying to send to any mailbox/alias I try to create.

"This is an automatically generated Delivery Status Notification.     

Delivery to the following recipients failed permanently:"

 

It does not show up in the list of alias and mailboxes under Manage my Mail

Webmail also does not let me log into it.

 

Regards,

 

Chris

LaurenB
Plusnet Help Team
Plusnet Help Team
Posts: 1,387
Thanks: 247
Fixes: 59
Registered: ‎07-12-2017

Re: No Payment Taken Since March!

Thanks for getting back to us Chris. Can you not log in to any of the mailboxes on webmail, or just the additional ones?

 

To help troubleshoot, would you be happy for us to try add a mailbox on from our side? If so, can you please just confirm this on the ticket here and let us know once you've replied.

 

If this post resolved your issue please click the 'This fixed my problem' button
 Lauren Barry
 Plusnet Help Team
Muppzlab
Hooked
Posts: 5
Registered: ‎03-09-2019

Re: No Payment Taken Since March!

Hi Lauren,

 

I can get into all of the existing mailboxes fine, and all of the existing alias are delivering to the correct mailboxes it is just any new ones I try to create.

I have updated the ticket with the name of the mailbox I am trying to create.

 

Regards,


Chris

adamwalker
Plusnet Help Team
Plusnet Help Team
Posts: 15,203
Thanks: 467
Fixes: 128
Registered: ‎27-04-2007

Re: No Payment Taken Since March!

Fix

Hi Chris, 

 

I've just dealt with that for you and have sent you a reply to the ticket. 

If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team
Muppzlab
Hooked
Posts: 5
Registered: ‎03-09-2019

Re: No Payment Taken Since March!

Thanks Adam,

Whatever you did seems to have fixed it, I can create mailboxes again.

Regards,

Chris

adamwalker
Plusnet Help Team
Plusnet Help Team
Posts: 15,203
Thanks: 467
Fixes: 128
Registered: ‎27-04-2007

Re: No Payment Taken Since March!

Hi Chris, in all honesty I didn't do anything but I'm happy to take the credit for it Wink

 

Please shout up if there's anything else we can do for you though.

If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team