cancel
Showing results for 
Search instead for 
Did you mean: 

Doing me proud? You're having a laugh!

iandhjolliffe
Newbie
Posts: 4
Registered: ‎26-10-2018

Doing me proud? You're having a laugh!

Signed up to switch from sky broadband and phone five weeks ago. Finally got switched a week ago (you lost my order!). A week on I get this :Your Home Phone order is currently being processed. We will keep you updated by email and tell you once your service is ready to use. Been using the phone for a week now. And can't access webmail.

I have not had an email to allow me to claim the £50 debit card.

And internet drops out   - something that never happened with Sky.

3 REPLIES
Plusnet Help Team
Plusnet Help Team
Posts: 6,113
Thanks: 591
Fixes: 229
Registered: ‎01-01-2012

Re: Doing me proud? You're having a laugh!

Sorry to hear that you're having issues.

It looks like the phone order wasn't showing as complete on your account. I've done this for you now and you'll receive a e-mail regarding this soon.

With regards to the cashback it can take up to 10 days from your broadband completing for you to receive the e-mail. If you haven't received it by the 19th let us know,

In terms of connection drops it doesn't look too bad from our end as shown below.

Can you confirm if the drops you're experiencing match up with the above? If you're connecting over a wireless connection we'd also recommend going through the steps here to see if they help

If this post resolved your issue please click the 'This fixed my problem' button
 Matthew Wheeler
 Plusnet Help Team
iandhjolliffe
Newbie
Posts: 4
Registered: ‎26-10-2018

Re: Doing me proud? You're having a laugh!

Drop outs much better but still can't access webmail and no sign of the cashback email which you thought I should recieved by Nov 19th.

Plusnet Help Team
Plusnet Help Team
Posts: 393
Thanks: 60
Fixes: 23
Registered: ‎26-03-2018

Re: Doing me proud? You're having a laugh!

Hi @iandhjolliffe,

I'm sorry to hear that you've experienced this issue with your services. I've taken a look into this issue this morning and raised a response via the open ticket on your account, which can be viewed here.

If this post resolved your issue please click the 'This fixed my problem' button
 Alex H
 Plusnet Help Team