cancel
Showing results for 
Search instead for 
Did you mean: 

Baffling failed payment redirect problems

caryh
Grafter
Posts: 49
Registered: 12-04-2013

Baffling failed payment redirect problems

Every time I login to the plusnet site, I am sent to the payment details page.

The page shows my DD details and also says I have a card payment setup but that is not the default payment method. I see this screen every time, even if accessing via direct urls to pages within the site.

Has anyone else had this issue, and if so how do I get this sorted, as I don't believe this should be correct behaviour, as it never used to happen.

Thanks
20 REPLIES
Plusnet Help Team
Plusnet Help Team
Posts: 4,902
Thanks: 1,067
Fixes: 238
Registered: 21-04-2017

Re: Baffling failed payment redirect problems

Hi there,

 

I'm not entirely sure what causes that.

Does this happen across multiple devices and web browsers?

 

Also, are you able to bypass the payment details page?

 

Cheers,

 

Anoush

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team
caryh
Grafter
Posts: 49
Registered: 12-04-2013

Re: Baffling failed payment redirect problems

Yes. It happens on both desktop and mobile versions of chrome and firefox, and on the desktop version of Edge. If I then click a link to any page that requires a user to be logged in, it goes straight to the payments page. A good exampke is the old linespeed page.Even if I have autologon setup so i should not need to keep logging in, clicking a bookmark to the page takes me to the login screen, and once logged in I get the payment methods page. If I then click the bookmark again I will go straight to the linespeed page. If I shut my browser and reopen it I have the login and payment pages next time I click the link. I assume the login evertime will be due to security to prevent anyone seeing any of the payment details, but the payment method screen coming up every time is quite annoying.
Plusnet Help Team
Plusnet Help Team
Posts: 4,902
Thanks: 1,067
Fixes: 238
Registered: 21-04-2017

Re: Baffling failed payment redirect problems

I'll get that flagged up with the relevant team for internal investigation.

In the meantime, I am very sorry for any inconvenience caused.

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team
RPi_User
Hooked
Posts: 9
Registered: 31-12-2012

Re: Baffling failed payment redirect problems

@caryh did you ever get this problem sorted out ?

@Gandalf I too have exactly the same problem and ticket No. #156075670 was placed with the Customer Service Team on Friday 18th August 2017. Please could you look into my problem that is identical to caryh's, as Customer Services couldn't rectify the problem and it's now becoming extremely annoying when logging on. Thanks

caryh
Grafter
Posts: 49
Registered: 12-04-2013

Re: Baffling failed payment redirect problems

@GarryWright

No, still the same unfortunately.
It does get annoying after a while.
RPi_User
Hooked
Posts: 9
Registered: 31-12-2012

Re: Baffling failed payment redirect problems

@caryh Sorry to hear that Plusnet still haven't managed to sort your problem out.

It looks like that we are in for a long wait, for a fix then Sad

Plusnet Help Team
Plusnet Help Team
Posts: 4,902
Thanks: 1,067
Fixes: 238
Registered: 21-04-2017

Re: Baffling failed payment redirect problems

I've raised this with our incident management team to further investigate, apologies for the inconvenience caused.

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team
caryh
Grafter
Posts: 49
Registered: 12-04-2013

Re: Baffling failed payment redirect problems

Still no change for me. Still happening.

RPi_User
Hooked
Posts: 9
Registered: 31-12-2012

Re: Baffling failed payment redirect problems

@caryh Unfortunately I am still experiencing the same problem as you, and I expect that we will both have this problem for a very long time.

I was so disappointed in the lack of customer support, that I emailed the CEO Andy Baker with my dissatisfaction.

He placed a dedicated PlusNet Support Member, to personally sort out the problem.

After weeks of trying various things including resetting my account, cancelling my Direct Debit payment and the PlusNet Support Member setting up my Direct Debit from Plusnet's end, the problem still remains.

Because the support team had now run out of ideas, the problem was passed to the Application Support Group.

I'm afraid that we will have this problem forever, because this is the last quote that I received before my ticket closed. 

"As per our conversation, the issue you are experiencing is one that has arisen every now and again over the past few years on different accounts. Currently based on how many accounts are affected and what the issue is it would seem that this problem has a very low priority and because of that I am unable to give you even an estimate of when this may be resolved. I am sorry that what (Name Removed) has tried with you has not worked, but it may be that the account is stuck in this way for a while to come."

As you can see, we are stuck with this problem until many more people experience and complain about the same problem.

Sorry to be bearer of bad news.Ticked off

 

Superuser
Superuser
Posts: 2,680
Thanks: 1,062
Fixes: 8
Registered: 10-04-2007

Re: Baffling failed payment redirect problems

Superuser citation

This topic has been cited by one of the Superusers; the purpose of which is to provide a note for information which might help to focus continued discussion (but might not result in a staff response).

 

caryh
Grafter
Posts: 49
Registered: 12-04-2013

Re: Baffling failed payment redirect problems

I don't know if someone has changed something, but it now seems that i'm not automatically redirected to the payment page every time I try to access my usage page.

It did happen when I last logged in on the main page, but since i've set the auto login again its not done it.

It used to do it regardless of auto login being set.

Community Gaffer
Community Gaffer
Posts: 12,966
Thanks: 753
Fixes: 70
Registered: 04-04-2007

Re: Baffling failed payment redirect problems

I looked into this year's ago. If I recall correctly, it's caused by a rogue flag in some of our legacy code, it's original intention was to push customers to the payment details pages if their card etc. has expired.
Hopefully it's been fixed in light of the problem ticket @Gandalf raised 🤞

Bob Pullen
Plusnet Products Team
If I've been helpful then please give thanks ⤵

RPi_User
Hooked
Posts: 9
Registered: 31-12-2012

Re: Baffling failed payment redirect problems

@caryh Thanks for the update and suggestion.

Unfortunately, I am still being diverted to the payment details page every time that I log on. So, nothing to date has changed for me.

Using the auto login feature appears to work for me occasionally, as long as I don't close the browser.

I am not deleting the cookies, history or temporary internet files on exit of the browser, to try to get this workaround to be successful. But, it's not been reliable for me so far. I will keep on trying!!

I'm really pleased that you have found a workaround to your problem ... I do hope it stays that way for you!!

 

 

@bobpullen I take it from your post, that you actually found the rogue flag causing the problem?

If so, is it complicated process to fix it? 

Superuser
Superuser
Posts: 9,056
Thanks: 507
Fixes: 44
Registered: 06-04-2007

Re: Baffling failed payment redirect problems

@RPi_User I'm sorry to hear you are still affected by this. The citation Maurice mentioned above remains open though sadly progress with it is poor. Due to the holidays opportunities to move forward are likely to be limited next week but we'll do our best in the new year.

To pick up on Bob's comment - do you have a credit card registered alongside your direct debit, and if so has it by any chance expired? I know this shouldn't matter if you don't owe anything but computers don't necessarily follow the same logic as we do. Huh

David