cancel
Showing results for 
Search instead for 
Did you mean: 

Tethering doesn't work on unlocked Lenovo B, or Huawei Y300

TehJumpingJawa
Newbie
Posts: 1
Registered: 27-07-2017

Tethering doesn't work on unlocked Lenovo B, or Huawei Y300

As per title; I have a pair of plusnet SIMs on 30 day rolling contract £5/month tariff.

 

Tried each SIM in both of the above handsets, neither gave internet access to tethered devices.

 

Swapped to a Three data SIM, and tethering worked perfectly for both handsets.

 

 

Is it a problem with the way plusnet have configured their SIMs/network?

Do plusnet know about this problem? As they clearly advertise tethering as being a supported feature.

 

Is there anything I can do to my devices to work around plusnet's misconfiguration?

1 REPLY
Community Veteran
Posts: 6,256
Thanks: 432
Fixes: 39
Registered: 30-07-2007

Re: Tethering doesn't work on unlocked Lenovo B, or Huawei Y300

It does seem that the PN network is configured to require certain setting on some phones.

My previous phone worked fine but the new one doesn't without changing the settings.

There are 2 possibilities (3 if you include rooting the phone - but we won't go there!) :-

1) add DUN (dial up networking ) to the APN you are using for PlusNet data access. This is done by adding ",DUN" to the APN type ( without the quotes ). Didn't work for me...

2) change the global setting such that DUN is not required for tethering, this worked for me!.

You need USB debugging enabled and ADB installed on a PC

 

To do so, you'll need the Android Debug Bridge.  You can install the Android SDK. Go ahead and download it from Android Developer site.

Once installed, make sure you have the correct USB driver for your Android device.  To verify, hook up your phone to your computer.  Open command prompt (I use Windows, if you use Mac, open Terminal).  Type in the command:

adb devices

You should see your device listed.  This is the proof that you have the correct USB driver.

Here's what you need to do:

1) Go to Android Debug Bridge Shell with the command
adb shell

2) Inside adb shell, type in the command
settings put global tether_dun_required 0

You are done!!  You can type
exit
to exit from adb shell.It's quite common

NB the first time you run 'ADB devices' the phone will ask you to authorise the PC to access it.

PS You'll probably find much better explanation and instructions by googling 'tether_dun_required'