cancel
Showing results for 
Search instead for 
Did you mean: 

Port complete, still no data on Android

Jenji
Newbie
Posts: 1
Registered: 11-01-2017

Port complete, still no data on Android

Like many others I have no mobile data since activation on Friday 6th Jan. My port request was completed yesterday with no complications, however I still have no mobile data!

I have tried:
- inputting the APN settings as shown on your website manually and making sure it is selected,
- turning data roaming on,
- turning off my phone, taking the SIM out, leaving for a few minutes, putting it back in, turning the phone back on,
- resetting APN,
- repeating all of the above.

Nothing works.

SIM analysis shows my "Network Type" to be "UMTS" which a quick Google search tells me is a 3G network type...?

I am glad to read that there has been a fix for new customers... but when will existing customers get their "fix?"

Will all those having this problem receive any sort of compensation? I only switched to plusnet mobile due to the double data offer, which is useless with no data! I am now considering switching back to giffgaff.
1 REPLY
Anonymous
N/A

Re: Port complete, still no data on Android

Hi @Jenji

 

Sorry to hear about this Jenji. 

Our Network Team have identified the issue that was preventing customers from using data and a fix was implemented last night for all new customers, as you know. We are now working on a fix for any existing customers, and we will have further information about this later today.