cancel
Showing results for 
Search instead for 
Did you mean: 

No mobile data. Switched to Plusnet from EE, running Android 6

kalniel
Newbie
Posts: 1
Registered: 08-01-2017

No mobile data. Switched to Plusnet from EE, running Android 6

Hi,

 

I recently switched to PlusNet from EE, so same network and I know the signal and phone are fine. But I can't get any connection to mobile data on my PlusNet sim. There is no data symbol appearing on my phone, I just get a (full) triangle for voice connection.

So far I have tried reseting network settings, and adding a new APN with the EE everywhere settings as mentioned elsewhere on these forums. I have also tried disabling wifi, not to mention turning the phone on and off.

Brownie points for having a customer desk open on a Sunday, but all they could tell me was that they are investigating a data issue and are collating information to help, but couldn't give any estimate for when it would be fixed.

Is there anything else I can try? I have to go to hospital next week so it's really bad timing to be without a data connection (because hospital wifi is.. well, you know). If not, can we get a refund for the downtime since we're paying for data that we're not getting?

Tags (2)
1 REPLY
adrens
Dabbler
Posts: 10
Thanks: 4
Registered: 08-01-2017

Re: No mobile data. Switched to Plusnet from EE, running Android 6

There are a lot of threads on here of a similar issue. Some suggest that a batch of SIM cards were made with incorrect provisions that affect data, I suspect they have old life mobile IMSI numbers that don't allow data on plusnet.

 

My wife's new SIM has the same issue and she just asked for a new SIM to be sent - will see if this one works!