Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

No calls, no texts, no 4G! 😑

Posts: 2
Registered: β€Ž24-11-2017

No calls, no texts, no 4G! 😑

I had my number ported over from Tesco a few months ago but as of last week 17.11.17 I'm unable to make calls, texts or access the internet through 4G.

Don't understand how my original sim card stopped working. Plusnet sent me another one which also doesn't work.

I've got a Samsung Galaxy S8 Plus & I've tried everything to get up & running but had no joy!

My wife has the exact same phone, on the exact same network & hers is fine so I guess that tells me it's my phone. Like I said I didn't do anything to it to stop it working

Please someone help before I leave Plusnet altogether
Rising Star
Posts: 71
Thanks: 18
Fixes: 1
Registered: β€Ž16-10-2015

Re: No calls, no texts, no 4G! 😑

Have you tried your SIM card in your wife's phone & hers in yours ?

Posts: 2
Registered: β€Ž24-11-2017

Re: No calls, no texts, no 4G! 😑

Yeah I have. My sim works in her phone but her sim doesn't work in mine. I've even tried her sim holder but that didn't work either.

It must be the phone. I just don't understand why it's decided to stop working.

As it stands there sending me yet another sim card but I don't think it'll make any difference.

So far I've tried the following:
Resetting network settings
Taking the sim out & back in
Adding the relevant APN settings

I've even updated my phone to the exact same firmware as my wife's s8 but that didn't work either

From what I've read on here Michael Williams is the guy to sort it
Plusnet Alumni (retired)
Plusnet Alumni (retired)
Posts: 142
Fixes: 7
Registered: β€Ž27-09-2017

Re: No calls, no texts, no 4G! 😑

Hi there @mike710_0!


I'm sorry to hear that you're having trouble using your phone since moving over to us.


It definitely does sound like it's a handset issue to me, which we would be unable to offer a fix for.

You could try contacting samsung directly, or take the phone into a local repair shop and see if they can help.


Is there any sort of error message or special symbol which appears instead of signal bars?


Thank you