cancel
Showing results for 
Search instead for 
Did you mean: 

No Service on one iPhone but okay on another

flamesong
Grafter
Posts: 63
Thanks: 8
Registered: ‎01-05-2011

No Service on one iPhone but okay on another

My girlfriend and I both have the same model iPhone, first generation SE, and both have Plusnet accounts. Because we live in a rural area which does not have the best coverage, we have a 3G femtocell.

I was just on hold trying to phone Plusnet about my broadband account when the line went quiet and I was unable to call back so I restarted my phone to try again but got No Service.

I reset the network settings and restarted it again, checked the settings, toggled between 3G and 4G in mobile data settings but could not get any service.

I checked my girlfriend's phone and she has both 3G and 4G signals but on checking, I noticed that her settings look different to mine - fo a start - in settings, mine says 'Mobile Data' and hers says 'Cellular' and within those settings, under EE, she has the option to choose 'plusnet' under Network Selection - mine only has WiFi Calling and Calls on Other Devices.

In General>About, hers says Network - plusnet, mine says Network - unavailable.

I understand that Plusnet piggy-backs EE's network so I am not surprised that EE appears in the settings but I don't really understand why she has a signal and I don't, suddenly - and why we have different looking settings on the same model phone and iOS version.

Anyway, at the moment, I can't use my phone even when I have 3G selected and I am sat next to the femtocell. I'd be grateful for any advice.

17 REPLIES 17
Baldrick1
Moderator
Moderator
Posts: 10,376
Thanks: 4,617
Fixes: 367
Registered: ‎30-06-2016

Re: No Service on one iPhone but okay on another

@flamesong 

Have you tried swapping SIMs to see if it’s a SIM or phone problem?

Moderator and Customer
If this helped - select the Thumb
If it fixed it,  help others - select 'This Fixed My Problem'

flamesong
Grafter
Posts: 63
Thanks: 8
Registered: ‎01-05-2011

Re: No Service on one iPhone but okay on another

Yes, I have thought of it but it will have to wait for now as the other phone is not currently available - but I have an old Nokia N95 I might try if I can find a SIM adapter.

newagetraveller
Pro
Posts: 662
Thanks: 137
Fixes: 2
Registered: ‎03-08-2012

Re: No Service on one iPhone but okay on another

If you have the original multi - s.i.m. "card" as originally supplied, it's possible to use the other sizes remaining in the "card" as an adaptor.

I keep those anyway, don't know about PN,but there is useful information on that. ie. s.i.m. number, P.U.K., s.i.m. PIN etc..

e.g. if the fruity phone is the smallest s.i.m.and the Nokia uses a larger one, the smaller s.i.m. may be inserted into what would be the correct size for that.

SammyM
Plusnet Help Team
Plusnet Help Team
Posts: 1,787
Thanks: 387
Fixes: 84
Registered: ‎22-01-2018

Re: No Service on one iPhone but okay on another

Hiya @flamesong

 

I'm really sorry you are experiencing an issue with your signal and for the hassle this is causing. 

 

While you are waiting to try an alternative phone, do you mind PM'ing me your mobile number and full name so that I can run some checks for you? 

If this post resolved your issue please click the 'This fixed my problem' button
 Sammy M - Sheffield Team
 Plusnet Help Team
flamesong
Grafter
Posts: 63
Thanks: 8
Registered: ‎01-05-2011

Re: No Service on one iPhone but okay on another

Thanks for the tip but I have a number of such bits and the cutouts are not all exactly the same so don't fit very well.

The Nokia N95 connected to my femtocell's 3G network without any issues.

When later I put the card back in my iPhone, and went through all the things that I had already done again, I got a one bar 4G signal which kept dropping whilst my girlfriend's iPhone was sat next to it with 2-3 bars on 4G. I tried the SIM in her iPhone and got 2-3 bars too.

They are the exact same phone and the antenna obviously works otherwise I wouldn't get a signal at all - so I don't know what to make of it except to wonder why her iOS software looks so different to mine.

Anyway, I have it set to 3G as I don't use anything requiring much bandwidth and at home where the 4G signal is unreliable, I can usually depend on the femtocell.

Baldrick1
Moderator
Moderator
Posts: 10,376
Thanks: 4,617
Fixes: 367
Registered: ‎30-06-2016

Re: No Service on one iPhone but okay on another

@flamesong 

Have you checked that both phones are on the latest version of IOS?

I have a previous version of the SE and it’s on v15.4.1.

Moderator and Customer
If this helped - select the Thumb
If it fixed it,  help others - select 'This Fixed My Problem'

flamesong
Grafter
Posts: 63
Thanks: 8
Registered: ‎01-05-2011

Re: No Service on one iPhone but okay on another

Both v15.4.1.

In Settings, does yours say 'Mobile Data' or 'Cellular'?

Baldrick1
Moderator
Moderator
Posts: 10,376
Thanks: 4,617
Fixes: 367
Registered: ‎30-06-2016

Re: No Service on one iPhone but okay on another

@flamesong 

Sorry I can’t help with that. This is my wife’s phone on a legacy PayGo account with no data allowance.

Moderator and Customer
If this helped - select the Thumb
If it fixed it,  help others - select 'This Fixed My Problem'

Townman
Superuser
Superuser
Posts: 21,742
Thanks: 8,841
Fixes: 130
Registered: ‎22-08-2007

Re: No Service on one iPhone but okay on another

@flamesong 

Is the range holder for both numbers the same - see here Number Rangeholder Lookup - NTA

 

"and within those settings, under EE, she has the option to choose 'plusnet' under Network Selection"

For total clarity, are you saying that her phone has an EE network option in addition to Plusnet, whereas yours only has "Plusnet"?

 

Whilst Plusnet uses the EE network, it does not have access to all of the EE network, specifically the 4G 800mHz band.  If for some oddity of your wife's SIM it is granting access to the FULL EE network, such might well explain your reported experience.

 

Under settings -> General -> About are the Network and Network provider details the same?

 

Anyone know how to find the details of the cell to which a phone is connected?  I seem to recall having done it ... but do not recall how!

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

flamesong
Grafter
Posts: 63
Thanks: 8
Registered: ‎01-05-2011

Re: No Service on one iPhone but okay on another

My number is Telefonica UK Limited - I ported it from O2 about 12 years ago - hers is EE.

My Settings look like this. EE is some kind of header. I can't show my girlfriend's as she is at work.

Townman
Superuser
Superuser
Posts: 21,742
Thanks: 8,841
Fixes: 130
Registered: ‎22-08-2007

Re: No Service on one iPhone but okay on another

@SammyM 

Is it possible that the originally EE number has (somehow) gained access to the 800mHz 4G service, but the previously O2 number does not have such access?

On an iPhone 11 on the EE network, the cited settings look like this...

20220507_130148569_iOS.png

How do yours and the GF's compare?

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

flamesong
Grafter
Posts: 63
Thanks: 8
Registered: ‎01-05-2011

Re: No Service on one iPhone but okay on another

I don't know if things have got a bit cross-threaded but I have my phone set to 3G by choice (I mentioned this in my opening post) because I spend most of my time at home which is poorly served by 4G. If I have the phone set to 4G and the signal drops, I lose the call - it doesn't switch to 3G - my femtocell provided an usually stable signal unless the broadband drops. If  My girlfriend, on the other hand, has hers set to 4G as she works in an area with a strong 4G signal but somehow gets a much better 4G signal at home than I do.

LaurenB
Plusnet Help Team
Plusnet Help Team
Posts: 2,577
Thanks: 508
Fixes: 131
Registered: ‎07-12-2017

Re: No Service on one iPhone but okay on another

Hiya @flamesong, thanks for getting back to us and for the information. 

 

Are you to access the APN settings and amend them on your handset? Might be worth comparing the APN settings of both your devices. 

 

I'd recommend checking yours are correct, you can what they are meant to look like here: https://www.plus.net/help/mobile/mobile-phone-and-voicemail-settings/

If this post resolved your issue please click the 'This fixed my problem' button
 Lauren Barry
 Plusnet Help Team
flamesong
Grafter
Posts: 63
Thanks: 8
Registered: ‎01-05-2011

Re: No Service on one iPhone but okay on another

The link you posted says:

iPhone

  1. Go to Settings > Mobile or Cellular > Mobile Data Network or Cellular Data Network > Access Point Names > Menu > New APN.

I can only go as far as 'Mobile Data' - there is no 'Mobile Data Network' to select. The closest is 'Mobile Data Options' but there is no 'Access Point Names' under that option.