cancel
Showing results for 
Search instead for 
Did you mean: 

Just switched from EE - now phone takes ages to get signal

DragonQ
Dabbler
Posts: 10
Thanks: 1
Registered: 01-09-2016

Just switched from EE - now phone takes ages to get signal

I just switched from EE to Plusnet a few days ago and am frustrated at how long my phone now takes to get a signal. I can't take my phone into my office so I always leave it in reception on airplane mode (to save battery). When I was with EE, I could pop down to reception, disable airplane mode, and have data within 5-10 seconds. Since moving to Plusnet, it's more like 1-2 minutes. I was also in a building with no signal earlier today and after leaving and walking to my car (at least two minutes) I still had no signal for Google Maps. Is this a common occurrence? Is there some setting on my phone I need to change to fix this? I've tried rebooting my phone a few times but it doesn't help.
3 REPLIES
Plusnet Help Team
Plusnet Help Team
Posts: 881
Thanks: 164
Fixes: 30
Registered: 25-11-2016

Re: Just switched from EE - now phone takes ages to get signal

Hi DragonQ,

Thanks for getting in touch with us!

I understand it can be frustrating when waiting for your SIM to connect to the network however, connectivity can be affected by many factors that may block or slow down the signal. Some of these factors include, the density of building materials, tree cover, weather conditions and how many people are using the network. 

We're not aware of any specific issues related to this on the network as a whole or had any recent complaints however, if you pop over to https://myaccount.ee.co.uk/networkchecker/checkservice and input your postcode, it will provide you of any issues if present, within that area.

- Rebeka 

 Rebeka Preston
 Plusnet Help Team
DragonQ
Dabbler
Posts: 10
Thanks: 1
Registered: 01-09-2016

Re: Just switched from EE - now phone takes ages to get signal

Sorry for the late reply but I've been trying different things to solve the issue, including re-inserting the SIM, trying both default APN settings and the ones listed on Plusnet's website, and even factory resetting my phone (!) and I still see the (even 2G) signal completely dropping sometimes. The Plusnet signal map shows my work building between Good and Very Good for 2G, Moderate for 3G, and between Very Good and Excellent for 4G. My home is in a Very Good signal area for 2G, 3G, and 4G. There are no signal issues in my area according to EE's network status checker, and the other indication that this is not a general problem is that my partner switched from EE to Plusnet at the same time as me, yet she has no issues. She has a Moto G5 Plus, whereas I have a Samsung Galaxy S5.

 

Could it be a faulty SIM?

Plusnet Help Team
Plusnet Help Team
Posts: 881
Thanks: 164
Fixes: 30
Registered: 25-11-2016

Re: Just switched from EE - now phone takes ages to get signal

Hi DragonQ,

From what you have described, it doesn't sound as if the SIM is faulty. Although you're experiencing a fluctuation in signal, it does still work and as advised above, signal can be affected by many factors.

Having said this, we can still send you out a replacement SIM card to troubleshoot and rule this out. 

If you could please send me a Private message with your details, I'll get the ball rolling.

- Rebeka Smiley

 Rebeka Preston
 Plusnet Help Team