cancel
Showing results for 
Search instead for 
Did you mean: 

6to4 stopped working

rmyorston
Not applicable
Posts: 2
Registered: ‎02-05-2015

6to4 stopped working

I have a static IPv4 address with PlusNet.  For the past year I've been using 6to4 on a CentOS 6 machine to provide IPv6 connectivity for my network.  (And for two years before that I was using OpenWRT on a Linksys NLSU2 to do the same.)
Yesterday, some time between 0745 and 0800, IPv6 stopped working.  All attempts to connect to IPv6 sites time out.
traceroute 192.88.99.1 shows 8 hops from my router to he.net.  traceroute6 to anywhere just shows lost of asterisks.
Any ideas?
Ron
4 REPLIES 4
matthews
Rising Star
Posts: 143
Thanks: 6
Fixes: 1
Registered: ‎13-08-2014

Re: 6to4 stopped working

The timing of it seems quite odd, but 6to4 was officially deprecated at the start of this year, so it could be that endpoints have started being shutdown. I'd recommend moving over to 6in4 instead (he provide free tunnels).
While not a resolution to your problem, the way 6to4 works is that it relies on 2 relays. One of them near you (the he.net one, which you can ping) and then one at the other side (to send the data back). This means that the issue may not be at your configuration, and it may not be the relay on this side but it could be the relay at the destination. So in theory the relay that is 8 hops away might still be functional and the rest have gone, or it may just be responding to pings and not actually working anymore.
rmyorston
Not applicable
Posts: 2
Registered: ‎02-05-2015

Re: 6to4 stopped working

6to4 remains broken so I gave up and got a 6in4 tunnel.
summers
Aspiring Pro
Posts: 268
Thanks: 49
Fixes: 1
Registered: ‎01-06-2014

Re: 6to4 stopped working

I use 6to4 at home, I didn't notice a glitch - then again I don't track how often I use an IPv6 number.
Anyway when I get home, I check I can still get onto the IPv6 network.
summers
Aspiring Pro
Posts: 268
Thanks: 49
Fixes: 1
Registered: ‎01-06-2014

Re: 6to4 stopped working

Yes checked when I got home.
IPv6 using 6to4 is still working:
IPv4: 80.189.105.42
IPv6: 2002:50bd:692a:10:bcff:3172:60c:44d9