cancel
Showing results for 
Search instead for 
Did you mean: 

Will have had no home phone for over a month!

Highlighted
Newbie
Posts: 3
Registered: ‎01-05-2015

Will have had no home phone for over a month!

Hi, our home phone 'died' (crackly and  buzzing dial-tone, callers told line as busy) and a ticket (102268594) raised on 10 April. initial fault was thought of being at the exchange, but when BT engineer came the next week he diagnosed fault on the line between the house and the junction in the street.  As we have a block-paved driveway the only option is to dig in a new line on the other side of the drive under soil. Dig  ETA 10 May, ETA completion 18 May!  Our area is being made ready for fibre and you can't drive in a street without passing a BT Openreach van!  Why does it take sooo long.  My mailbox is now full so I will have no idea whose been ringing me since about a week ago, and as we have recently moved house there are probably a few important calls waiting for my action - or missed altogether!  Been with PN some and recommended a few of family too so hope this is resolved very soon, but sadly as we are not a 'BT' customer its not in their interests to expedite the matter!  Angry
3 REPLIES 3
Highlighted
Plusnet Help Team
Plusnet Help Team
Posts: 2,188
Thanks: 47
Fixes: 18
Registered: ‎24-07-2014

Re: Will have had no home phone for over a month!

Welcome to the forums,
Sorry to see what you are going through. It's always frustrating when dig work is required as, as much as I wish this wasn't true, it always seems to take ages. Part of the problem is that permission is needed to dig the public path, as well as your own land.
I wish we could get this done quicker for you, but it seems unlikely.
If this post resolved your issue please click the 'This fixed my problem' button
 Tony T
 Plusnet Help Team
Highlighted
Newbie
Posts: 3
Registered: ‎01-05-2015

Re: Will have had no home phone for over a month!

Hi,is there ANY update on this?  I have updated my question a few days ago but no response as it now well past the ETA for the dig to start.  Also, my broadband (still thankfully just working) keeps losing internet access even though my routers says it is connected, i get an IP address, DNS etc.  I have to manually disconnect/reconnect to get it to work again.  Is there any way of minimising this as we work from home via a secure link and it's annoying to have to keep resetting the router!
Thanks
Highlighted
Legend
Posts: 17,723
Thanks: 598
Fixes: 168
Registered: ‎05-04-2007

Re: Will have had no home phone for over a month!

Unfortunately the ticket on your account seemed to get stuck, I've kicked this over to the right place now. Really sorry for the delay, the faults team will pick this up asap.
If this post resolved your issue please click the 'This fixed my problem' button

Former Plusnet Staff member. Posts after 31st Jan 2020 are not on behalf of Plusnet.