cancel
Showing results for 
Search instead for 
Did you mean: 

Strange setting!!!

Community Veteran
Posts: 7,149
Thanks: 51
Fixes: 2
Registered: 30-08-2007

Strange setting!!!

Every time I click my "home" page in FireFox the "Tools/Options" menu bar tab is added to the menu bar. It doesn't open unless I click the tab. I can end up with dozens of these tabs all quietly sitting in the menu bar if I fail to remember to close the tabs.
I'm not sure why its happening, or what setting to change to stop it, there's nothing obvious in the Options page.
Any one here know?
Experience; is something you gain, just after you needed it most.

When faced with two choices, simply toss a coin. It works not because it settles the question for you. But because in that brief moment while the coin is in the air. You suddenly know what you are hoping for.
9 REPLIES
WTF
Grafter
Posts: 673
Thanks: 1
Registered: 14-09-2012

Re: Strange setting!!!

Not behaviour I've ever seen ..
I assume you don't have Settings as your home page.
I would start with disabling any add-ons, see if that fixes it.
Moderator
Moderator
Posts: 25,756
Thanks: 1,120
Fixes: 47
Registered: 14-04-2007

Re: Strange setting!!!

Not sure why you get multiple 'Options' tabs.
However I did notice a few weeks ago while setting up my Home tabs that the 'Options' page which I had open in order to perform this operation was added as a Home tab Huh
I had to go into Options and edit it off the list.
It didn't used to do this so I suspect a bug.
I use Waterfox, a 64 bit Firefox variant.
Customer and Forum Moderator.
Product of the Tyrell Corporation
Community Veteran
Posts: 2,282
Thanks: 218
Fixes: 1
Registered: 04-08-2009

Re: Strange setting!!!

Any good?
https://support.mozilla.org/en-US/questions/1063841

Quote
  Chosen solution
Hi, FredMcD's advice is what you need: You can go back to the old Options window by: Type about:config into the address bar, press Enter, accept the warning, scroll down to browser.preferences.inContent and double click to change 'Value' from True to False, taking care not to alter anything else. You may then need to restart Firefox.
Community Veteran
Posts: 18,545
Thanks: 191
Registered: 12-08-2007

Re: Strange setting!!!

Whenever I've had a problem with Firefox or Thunderbird I've posted my query on the Mozilla forums. Always got an answer from a well informed  person, generally one of their mods

http://forums.mozillazine.org/
Community Veteran
Posts: 7,149
Thanks: 51
Fixes: 2
Registered: 30-08-2007

Re: Strange setting!!!

Interestingly (or otherwise depending on your point of view) I don't have "browser.preferences.inContent" to change to false in my "about:config" list. However my Firefox is v44.0.2 that referred to in the link is v38. So maybe there's more information in artmo's suggestion.
But, thanks for the suggestions guy's.
Experience; is something you gain, just after you needed it most.

When faced with two choices, simply toss a coin. It works not because it settles the question for you. But because in that brief moment while the coin is in the air. You suddenly know what you are hoping for.
Community Veteran
Posts: 5,336
Thanks: 607
Registered: 23-09-2010

Re: Strange setting!!!

That was removed in v42.
Community Veteran
Posts: 7,149
Thanks: 51
Fixes: 2
Registered: 30-08-2007

Re: Strange setting!!!

S'pose you wouldn't know what replaced it?
Experience; is something you gain, just after you needed it most.

When faced with two choices, simply toss a coin. It works not because it settles the question for you. But because in that brief moment while the coin is in the air. You suddenly know what you are hoping for.
Community Veteran
Posts: 5,336
Thanks: 607
Registered: 23-09-2010

Re: Strange setting!!!

No idea.
Firefox has become a bit of a mystery to me so I stick with an old version of Palemoon.
I only use the latest Firefox when I'm forced to.
Even then it's only a brief use of a stand alone version.
Community Veteran
Posts: 7,149
Thanks: 51
Fixes: 2
Registered: 30-08-2007

Re: Strange setting!!!

Well, WFT and Strat between them had the answer, And predictably was dead simple. My home page in "Options/General" was suffixed with the Options URL, leading to both being opened every time the home page was clicked. The Options tab was cumulative though.
a) I hadn't noticed.
b) how it got there I have no idea.
I did though recently have to reset my home page as a software down load loaded itself as my home page, without any indication in its setup it was going to, something I find very annoying.
Thanks guys.
Experience; is something you gain, just after you needed it most.

When faced with two choices, simply toss a coin. It works not because it settles the question for you. But because in that brief moment while the coin is in the air. You suddenly know what you are hoping for.