cancel
Showing results for 
Search instead for 
Did you mean: 

Plusnet web hosting and HTML5 Video

Mk_1
Newbie
Posts: 2
Thanks: 2
Registered: 08-11-2017

Plusnet web hosting and HTML5 Video

Hi, has anyone had issues with HTML5 Video from the basic Plusnet web server?   I can't seem to get it to work, the player appears, but with a frowny face where the first frame of the video should be. I know the file exists as  I can HTTP to it and I get the binary file appearing as the odd characters they'd appear in HTTP, so it isn't that it can't find the file.  But as an MP4 file in an HTML page it doesn't stream, and I can't find any error message, I simply get a frowny faced page icon, and no indication as to what the problem is. 

I was hoping someone might know, is it the mimetype issue?  I can't find anything on plusnet that tells me about video.  The video and page works fine on my local windows host, but the plusnet server is Apache, so I'm wondering if it is deliberately set up to prevent streamed video.

TIA

 

2 REPLIES
Superuser
Superuser
Posts: 8,951
Thanks: 451
Fixes: 38
Registered: 06-04-2007

Re: Plusnet web hosting and HTML5 Video

An MP4 video embedded in an HTML5 page on Plusnet basic webspace plays fine for me. This is using the Microsoft Edge browser on Windows 10 Fall Creators Update.

When you uploaded the MP4 file was the transfer done in binary mode?

David
Mk_1
Newbie
Posts: 2
Thanks: 2
Registered: 08-11-2017

Re: Plusnet web hosting and HTML5 Video

Hi David,

 

Thanks for the reply, I've discovered the problem, I had in fact managed to mess up the src by adding a character which I then missed when I copied and pasted to test the existence of the file based on the src string!  How often it is such stupid things I miss :-(

It all works now.

John