cancel
Showing results for 
Search instead for 
Did you mean: 

Xbox Live, Belkin Router and MTU issue

munkimatt
Grafter
Posts: 35
Registered: 17-09-2009

Xbox Live, Belkin Router and MTU issue

Hi all, looking for a bit of help with a confusing issue.
I've having a few issues with my broadband at home (see http://community.plus.net/forum/index.php/topic,81294.0.html, in the meanwhile I'm attepting to monitor my connection with a non-Plusnet router, a Belkin F5D8635-4 v1 model. It seems to be doing well, my speed stays stable but with one huge issue, I cannot connect to Xbox Live on my 360.
When it attempts to connnect I'm informed there's an error and to do a network test. That test then tells me that my MTU is too low and Xbox LIve has a minimum MTU of (off the top of my head) 1364. The problem is that when I go to the router settings and look at the MTU it's set at (again, off the top of my head) 1432.
I spent last night moving the MTU up and down, from the minimum up to 1500 and found that at no point could I connect to Xbox Live. I plugges my Plusnet router back up and it connected to Xbox Live no problems.
I've searched around on the internet to no avail, looked for a new router firmware (couldn't find one), I've placed the Xbox in the DMZ, I've forwarded ports, I've prayed to Zeus, nothing has worked. Any ideas folks? My evenings don't seem complete unless I'm being verbally abused by someone who's doing their GCSEs.
1 REPLY
Talon
Newbie
Posts: 1
Registered: 27-12-2009

Re: Xbox Live, Belkin Router and MTU issue

Hi,
I have the same router  and had a nightmare trying to get my xbox online. Try the following  set MTU to 1364  as you mentioned.  Give your Xbox a static IP address
Then set the following virtual servers on the router
Dscription          Inbound Port                                  Type                          Private IP Address              Private Port
Xbox-rule1              80                                                TCP                        <your static xbox ip>          80
Xbox-rule2              88                                                TCP                        <your static xbox ip>          88
Xbox-rule3              3074                                        TCP/UDP                  <your static xbox ip>          3074
Xbox-rule4              53                                            TCP/UDP                  <your static xbox ip>          53
Save setting and reboot, and try to connect. I am not sure you need Port 80, but I had to do it for it to connect to Xbox live. In the netwrok test, I still get  warning indicating that not all features of the Xbox will work, but so far  everything seems to be fine.  good luck