cancel
Showing results for 
Search instead for 
Did you mean: 

Lag / Packet loss

Highlighted
Dabbler
Posts: 21
Thanks: 3
Registered: ‎30-06-2018

Lag / Packet loss

Hopefully a temporary issue this weekend, but my connection has been quite dire, severe lag and general slow speeds. Still 30% packet loss. 

I've power cycled my router and PC, flushed DNS and nothing seems to fix it. 

Sadly I think this is a common occurrence, every other week I have a day of crappy internet. Whilst i'm more of a power user for gaming, netflix, etc I feel like i'll be going back to BT so that I have more of a reliable connection. 

 

C:\Users\spaced>ping google.co.uk -n 50

Pinging google.co.uk [172.217.169.3] with 32 bytes of data:
Reply from 172.217.169.3: bytes=32 time=41ms TTL=54
Reply from 172.217.169.3: bytes=32 time=41ms TTL=54
Reply from 172.217.169.3: bytes=32 time=41ms TTL=54
Request timed out.
Reply from 172.217.169.3: bytes=32 time=37ms TTL=54
Reply from 172.217.169.3: bytes=32 time=38ms TTL=54
Request timed out.
Reply from 172.217.169.3: bytes=32 time=40ms TTL=54
Request timed out.
Reply from 172.217.169.3: bytes=32 time=28ms TTL=54
Reply from 172.217.169.3: bytes=32 time=40ms TTL=54
Reply from 172.217.169.3: bytes=32 time=25ms TTL=54
Request timed out.
Reply from 172.217.169.3: bytes=32 time=41ms TTL=54
Request timed out.
Reply from 172.217.169.3: bytes=32 time=40ms TTL=54
Request timed out.
Reply from 172.217.169.3: bytes=32 time=44ms TTL=54
Reply from 172.217.169.3: bytes=32 time=33ms TTL=54
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from 172.217.169.3: bytes=32 time=36ms TTL=54
Reply from 172.217.169.3: bytes=32 time=41ms TTL=54
Request timed out.
Reply from 172.217.169.3: bytes=32 time=40ms TTL=54
Reply from 172.217.169.3: bytes=32 time=38ms TTL=54
Reply from 172.217.169.3: bytes=32 time=40ms TTL=54
Reply from 172.217.169.3: bytes=32 time=32ms TTL=54
Reply from 172.217.169.3: bytes=32 time=40ms TTL=54
Reply from 172.217.169.3: bytes=32 time=40ms TTL=54
Reply from 172.217.169.3: bytes=32 time=39ms TTL=54
Reply from 172.217.169.3: bytes=32 time=39ms TTL=54
Request timed out.
Reply from 172.217.169.3: bytes=32 time=31ms TTL=54
Request timed out.
Reply from 172.217.169.3: bytes=32 time=23ms TTL=54
Reply from 172.217.169.3: bytes=32 time=40ms TTL=54
Reply from 172.217.169.3: bytes=32 time=40ms TTL=54
Reply from 172.217.169.3: bytes=32 time=34ms TTL=54
Reply from 172.217.169.3: bytes=32 time=41ms TTL=54
Request timed out.
Reply from 172.217.169.3: bytes=32 time=24ms TTL=54
Request timed out.
Reply from 172.217.169.3: bytes=32 time=40ms TTL=54
Reply from 172.217.169.3: bytes=32 time=41ms TTL=54
Reply from 172.217.169.3: bytes=32 time=40ms TTL=54
Reply from 172.217.169.3: bytes=32 time=40ms TTL=54
Reply from 172.217.169.3: bytes=32 time=41ms TTL=54

Ping statistics for 172.217.169.3:
Packets: Sent = 50, Received = 35, Lost = 15 (30% loss),
Approximate round trip times in milli-seconds:
Minimum = 23ms, Maximum = 44ms, Average = 37ms

10 REPLIES 10
Highlighted
Plusnet Help Team
Plusnet Help Team
Posts: 16,851
Thanks: 5,151
Fixes: 867
Registered: ‎21-04-2017

Re: Lag / Packet loss

I believe Google like many others rate-limit ICMP so a lot of ping requests will be rejected as their routers are simply busy prioritising normal traffic instead of responding back. This makes it look like there's packet loss on a ping or traceroute. 

The lag and slow speeds you've said you're seeing doesn't sound good though. Switching to a provider who uses the exact same equipment at the cabinet/exchange as us probably wouldn't move things forward to a resolution.

Is your PC connected to your router using an ethernet cable and what speeds do you get when you go to a speed test website like Here? What are also your speed estimates for your line when you type in your landline phone number Here?

Do you have your router connected into the test socket as explained Here bypassing any internal wiring or extensions?

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team
Highlighted
Dabbler
Posts: 21
Thanks: 3
Registered: ‎30-06-2018

Re: Lag / Packet loss

Hello Gandalf

I know what you're saying, but wouldn't it be in BT's interest to prioritise their own customers? Smiley

I get 33.2 MBps which is about right for my achievable speeds. But, it's more packet loss vs the speed.

Recently (this year) had quite a few problems with the connection and a brand new socket and test socket has been installed where the router plugs into.

I'm plugged into the Ethernet port. 

Strangely the connection seems stabl now, check this out:

C:\Users\macfa>ping google.co.uk -n 25

Pinging google.co.uk [216.58.206.99] with 32 bytes of data:
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=14ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=13ms TTL=54
Reply from 216.58.206.99: bytes=32 time=14ms TTL=54

Ping statistics for 216.58.206.99:
Packets: Sent = 25, Received = 25, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 13ms, Maximum = 14ms, Average = 13ms

Highlighted
Plusnet Help Team
Plusnet Help Team
Posts: 16,851
Thanks: 5,151
Fixes: 867
Registered: ‎21-04-2017

Re: Lag / Packet loss

Thanks for getting back to us,
The BT you’re referring to would be BT Retail who in this instance are a provider just like ourselves or anyone else who chooses to use the suppliers of the broadband infrastructure Openreach and/or Wholesale. They aren’t allowed to provide something to BT (Or any providers of the BT Group) that other providers outside or within the Group can’t get.
It’s easier to diagnose a speed problem as opposed to simply packet loss/lag, because more often than not, lag is normally just a side-effect as opposed to a cause.
If you can leave this with me I’ll be happy to check things out tomorrow when I’m back in the office.
If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team
Highlighted
Dabbler
Posts: 21
Thanks: 3
Registered: ‎30-06-2018

Re: Lag / Packet loss

Thank you Gandalf. 

I want to stay with PlusNet - simply based on how great the customer service is... The response on this forum was fantastic.

Let me know if you have anything else I can try.

 

Highlighted
Plusnet Help Team
Plusnet Help Team
Posts: 16,851
Thanks: 5,151
Fixes: 867
Registered: ‎21-04-2017

Re: Lag / Packet loss

Thanks for getting back to us @spaced 

I've tested your line and everything is showing as spot on:

GEA Test Detail
Circuit ID NA Service ID [redacted]
 
 
Test Outcome Pass
Test Outcome Code GTC_FTTC_SERVICE_0000
Description GEA service test completed and no fault found .
Main Fault Location OK
Sync Status In Sync
Downstream Speed 35.8 Mbps
Upstream Speed 6.4 Mbps
Appointment Required N
Fault Report Advised N
NTE Power Status PowerOn
Voice Line Test Result Pass
Bridge Tap Not Detected
Radio Frequency Ingress Not Detected
Repetitive Electrical Impulse Noise Not Detected
Cross Talk Not Detected
Estimated Line Length In Metres 835.7
Upstream Rate Assessment Reasonable
Downstream Rate Assessment Reasonable
Interference Pattern Not Detected
Service Impact No Impact Observed
Home Wiring Problem Not Detected
Downstream Policing Discard Rate 0.0
Customer Traffic Level Upstream and Downstream Traffic Detected
Technology VDSL
Profile Name 0.128M-40M Downstream, Error Protection Off - 0.128M-10M Upstream, Error Protection Off
Time Stamp 2019-07-16T15:00:00
Parameters MIN MAX AVG
Down Stream Line Rate 35.1 Mbps 36.3 Mbps 35.8 Mbps
Up Stream Line Rate 6.4 Mbps 6.9 Mbps 6.7 Mbps
Up Time 787.0 Sec 900.0 Sec 899.7 Sec
Retrains 0.0 1.0 0.0
Current and Last 15 Minute Bin Performance
Parameters Last Traffic Count(Upto 15 mins) Current Traffic Count(Upto 15 mins)
Start Time Stamp 2019-07-29T14:34:13.342+01:00 2019-07-29T14:49:13.342+01:00
Ingress Code Violation 0 2
Egress Code Violation 0 0
Errored Seconds 5 2
Severely Errored Seconds 0 0
Unavailable Seconds 0 0

There's also no congestion showing on the BT infrastructure at the exchange.

Apart from two drops yesterday your connection seems to be stable:

image15644086964260

Do you experience the same issues across multiple games assuming you play any others? Also are you able to try a different computer to narrow down where the issue lies?

It may also be worth doing a factory reset of the router to see if that clears the issue.

Finally what do traceroutes look like to the gaming server or a server like pingbox1.thinkbroadband.com?

Let us know how it goes.

 

[edit]

@spaced wrote:

I want to stay with PlusNet - simply based on how great the customer service is... The response on this forum was fantastic.

Cheers for the positive feedback and kind words. Thumbs_Up

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team
Highlighted
Dabbler
Posts: 21
Thanks: 3
Registered: ‎30-06-2018

Re: Lag / Packet loss

Hello there.

The two drops were myself power cycling the device. I'll look at your suggestions. 

Highlighted
Plusnet Help Team
Plusnet Help Team
Posts: 16,851
Thanks: 5,151
Fixes: 867
Registered: ‎21-04-2017

Re: Lag / Packet loss

Cool. Keep me posted on how things go. Smiley

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team
Highlighted
Plusnet Help Team
Plusnet Help Team
Posts: 16,851
Thanks: 5,151
Fixes: 867
Registered: ‎21-04-2017

Re: Lag / Packet loss

Hey, I’m just wondering how you’ve got on with this?

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team
Dabbler
Posts: 21
Thanks: 3
Registered: ‎30-06-2018

Re: Lag / Packet loss

Hello there!

I've been super busy so haven't had chance to do this yet.

Highlighted
Plusnet Help Team
Plusnet Help Team
Posts: 16,851
Thanks: 5,151
Fixes: 867
Registered: ‎21-04-2017

Re: Lag / Packet loss

Ah fair that's cool.

I know the feeling, life can get in the way. Cheesy

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team