Showing results for 
Search instead for 
Did you mean: 

Problem Renewing FTTP Contract

Posts: 2
Registered: ‎29-04-2020

Problem Renewing FTTP Contract

For some reason known only to Openreach, they were unable to provide me with FTTC but were able of offer FTTP. As a result I went with the PLUSNet FTTP trial a few years back.  Now that trail has finished I'm facing problems renewing my contract at a sensible price. While PlusNet is offering new/renewals FTTC fibre at £22.99 for  some reason they say they can't offer me a renewal on the same basis.

I would have thought that as everything is already set up and running I could have been offered the same deal - especially as the contract I am on is effectively a FTTC product run over FFTP technology, with speed capped to around 40mbps. (This suits me fine - I don't need anything faster)

I have checked with Openreach and they tell me that FTTC is still not available at my address and copper broadband would be limited to about 10 mpbs so switching to these is not an option.

Looks like I'm stuck between a rock and a hard place.  Has anyone had any experience in extending their PlusNet FTTP service at a reasonable price or know any other ISPs other than BT who can offer a reasonably priced FTTP service.

Posts: 29,653
Thanks: 6,668
Fixes: 1,485
Registered: ‎11-01-2008

Re: Problem Renewing FTTP Contract

Moderators Note

This topic has been moved from Fibre to FTTP Trial

Customer / Moderator
If it helped click the thumb
If it fixed it click 'This fixed my problem'
Rising Star
Posts: 51
Thanks: 20
Registered: ‎16-10-2015

Re: Problem Renewing FTTP Contract

There's a similar thread, with an answer, here:


Even on a non-contracted rate for the service I have, I haven't found an enduring better price anywhere else.

Posts: 41
Thanks: 5
Fixes: 3
Registered: ‎23-12-2019

Re: Problem renewing FTTP Contract

Thank you for your patience on this post.


Having been able to review your account I'm pleased to see you have been in touch with our re contacts team an arranged a new package.


I trust this was to your satisfaction.




If this post resolved your issue please click the 'This fixed my problem' button
 Kevin T
 Plusnet Help Team