cancel
Showing results for 
Search instead for 
Did you mean: 

Router issue causing low speeds?

nickroyle
Newbie
Posts: 5
Registered: 12-12-2010

Router issue causing low speeds?

Just curious if anyone else has had a similar experience or has any pearls of wisdom to share!
Expected speeds - approx 37Mbps download. Since install I've had speeds from 18Mbps (best case) to 6Mbps (worst case).
Plusnet support are a bit flummoxed. Done numerous tests and apparently my modem is syncing at very close to 40Mbps.
BT engineer visit booked for Friday, but as a 'last test' Plusnet support asked me to set up a PPPoE connection directly via an Ethernet connection to the BT modem - done this tonight and getting 26 to 32Mbps.
So - a faulty router? Am using the Plusnet-supplied N150/WNR1000 router.
3 REPLIES
phil4
Grafter
Posts: 244
Registered: 13-12-2007

Re: Router issue causing low speeds?

In the past things that might have caused issues like this are:
1) Underpowered router... it is just a mini computer after all, and so a slow CPU with lots of work to do can cause this sort of issue.
2) Lots of "protection" causing the above eg: DOS defence, Malware/Antivirus protection, content/URL filtering.
3) NATing - unlikely, but even Voda networks setup their routers and firewalls without NAT these days.... strangely.
puffin
Grafter
Posts: 71
Registered: 24-03-2009

Re: Router issue causing low speeds?

Nick, I'm sure support have already asked this, but it doesn't hurt to confirm it.
Are you connected to the router via ethernet or wireless?  If ethernet are you getting the full 100BaseT full duplex or something less?
nickroyle
Newbie
Posts: 5
Registered: 12-12-2010

Re: Router issue causing low speeds?

Connections direct to the router for testing have been Ethernet.