cancel
Showing results for 
Search instead for 
Did you mean: 

new user poor speed

jimpotter2017
Newbie
Posts: 3
Registered: 30-10-2017

new user poor speed

hi.

 

so a new user to Plusnet.

have arrived home after holiday tot he new service.

i was told i should get between 62 - 80 mb .

current speed is 24mb.

i have come from a virgin 200mb connection and will be perfectly happy with 70 - 80mb.

 

is it normal for the speed to start off so low ?Huh

router is connected to the master socket etc.

 

thx jim

3 REPLIES
Plusnet Help Team
Plusnet Help Team
Posts: 12,763
Thanks: 108
Fixes: 32
Registered: 27-04-2007

Re: new user poor speed

Hi Jim, 

 

Cheers for deciding to join us and welcome to the forums too!

 

 

I've just been running diagnostics and everything looks in order from our point of view. 

 

Are you connecting wirelessly? If so that may benefit from following the checks here: https://goo.gl/Bw9Upq

If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team
jimpotter2017
Newbie
Posts: 3
Registered: 30-10-2017

Re: new user poor speed

Hi Adam .

 

it was being checked via wireless .

although the previous router gave much better speeds and was also dual band.

i will run a wired check tonight , but last night bbc iplayer was stuttering .

not something that should happen even on a low speed connection

 

ill check out the checks you suggest

 

Jim

Plusnet Help Team
Plusnet Help Team
Posts: 12,763
Thanks: 108
Fixes: 32
Registered: 27-04-2007

Re: new user poor speed

OK Jim, keep us posted and I'll make sure we follow things up as needed.

If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team