cancel
Showing results for 
Search instead for 
Did you mean: 

iPlayer drops connection

FIXED
Albert100
Newbie
Posts: 2
Thanks: 1
Registered: ‎22-09-2021

iPlayer drops connection

I have an issue with iPlayer on my Sony smart TV.  It drops connection, no buffering - if you go back to the home page you can resume the programme.  It usually returns to just before the point it dropped.  I have tested some programmes whilst using my mobile as a hot spot for the TV and it doesn't happen.  No other playback Apps have the same problem.  Any ideas?

3 REPLIES 3
Gandalf
Plusnet Help Team
Plusnet Help Team
Posts: 21,367
Thanks: 7,271
Fixes: 1,225
Registered: ‎21-04-2017

Re: iPlayer drops connection

Fix

Thanks for your post @Albert100 and welcome to our Community Forums.

I'm sorry to see you're having issues watching iPlayer on your Smart TV. 

I'd recommend changing the wireless channels within your router's settings as this sort of issue is generally an issue with how the TV gets the wireless signal from the router. I've included some steps below if you're unsure how to. 

1. Go to the router's homepage at http://192.168.1.254
2. Click on the Advanced Settings tab
3. Type in the admin password found from the back of the router and click the OK button
4. Click on the Continue to Advanced Settings button then the Wireless tab
5. From here you'll be able to change the wireless channel.

It's generally a case of trial and error, changing one channel and retesting to see how it goes, but if you download a wireless analyser app, you should be able to find out which channels are least being used to make things a bit easier.

I'd also recommend carrying out the below steps to make the 5GHz wireless network visible.

By default this is merged into a single network name that your devices see, so your router will automatically connect your devices onto whichever frequency that it believes to be best, whether that'd be the dual band 5GHz or the regular 2.4GHz wireless but sometimes it's better to manually choose which one to use.

By carrying out these steps, you should be able to manually connect your devices on to the 5GHz wireless network which is generally faster and doesn't succumb to interference in the same way as the 2.4GHz network.

1. Go to the router's homepage at http://192.168.1.254
2. Click on the Advanced Settings tab
3. Type in the admin password found from the back of the router and click the OK button
4. Click on the Continue to Advanced Settings button then the Wireless tab
5. Click on the 5GHz Wireless tab
6. Select No next to Sync with 2.4GHz
7. Change the name of the Wireless SSID to something different
8. Click the Apply button and wait for the change to be applied

Once you've done this in the list of available wireless networks in your device settings you should now see a new wireless network ending in 5GHz (or it may be named something different if you've customised the name of it while in your router's settings). Try connecting the devices you have closest to your router onto this.

Let us know how you get on. Smiley

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team
Albert100
Newbie
Posts: 2
Thanks: 1
Registered: ‎22-09-2021

Re: iPlayer drops connection

Thank you Gandalf.  There was a lot of trial (and error!) but the proposed actions do appear to have sorted the issue out with regard to iPlayer.  All I need now is amore stable fibre connection and I'll be there.

Thanks again!

adam945
Plusnet Help Team
Plusnet Help Team
Posts: 1,309
Thanks: 296
Fixes: 59
Registered: ‎01-12-2020

Re: iPlayer drops connection

Hello @Albert100

Thanks a lot for reaching out and I'm really glad to hear that the suggestions offered by @Gandalf have improved your wireless service.

I've taken a look at the line and you're right, something does not seem quite right. Speeds have been dropping gradually and dropouts can be seen. I've tested the lie though and can't find any underlying issue.

Going forward, please have a read through our Troubleshooting Guide to see if you're able to resolve the issue sooner. When testing, please remove the faceplate from your Master Socket, and connect your router directly into the test socket which lies behind it. Avoid using any extension cables / sockets too if possible.

Troubleshooting Guide - https://www.plus.net/help/broadband/connection-troubleshooting/

See how you get on, and if the problem persists, head across to faults.plus.net and raise this issue with our Technical Support Team. In the Additional Information section, pop in some dates and times that you'd be available for an engineer visit, our Technical Support Team will then be in touch, though feel free to reach out when you've done it and I'll be happy to get the fault raised with our suppliers.

 

Capture.PNG

 Adam
 Plusnet Help Team - Leeds