cancel
Showing results for 
Search instead for 
Did you mean: 

iFit Live Module won't connect to router and I need to be able to port forward??

BarefootWandere
Dabbler
Posts: 12
Registered: 18-12-2014

iFit Live Module won't connect to router and I need to be able to port forward??

Hi All - not long since changed providers from virginmedia to plusnet (due to moving house)
I've Been having problems configuring my iFit Live Module with my Technicolor TG582n router. The iFit module connects wirelessly from my treadmill and when I test the connection I plug the module into my PC via usb. I run the iFit software but it refuses to connect.
When the module wouldn't connect to the router I was advised by iFit to change the security settings to WPA-PSK instead of the default combined one of WPA-PSK + WPA2-PSK - tried this and the module still wouldn't connect to the router.
I did manage to connect using the WEP setting but this is insecure and would mean switching from one setting back to another each time I used the treadmill which is a pain in the backside!
One solution plusnet advised was to try port forwarding to open the port for iFit module use. The advisor sent me to a website explaining all about it but I'm having difficulty understanding what port forwarding is and how it helps me. I haven't tried anything yet but I've downloaded some software which is supposed to let me do this, called simple port forwarding
Can anyone shed any light on this?
Surely there's a way of configuring the Module to connect using the WPA2-PSk security settings?
Does anybody know what to do especially re port forwarding if indeed this is the right way to go.
Thanks in Advance
26 REPLIES
Community Veteran
Posts: 1,829
Thanks: 93
Fixes: 5
Registered: 21-01-2013

Re: iFit Live Module won't connect to router and I need to be able to port forward??

From  https://www.ifit.com/install
Quote
To activate and use your iFit® Module, you will need the following:
   A Personal Computer (PC or Macintosh) with at least one available USB port.
   A wireless 802.11b router with SSID broadcast enabled (hidden networks are not supported).
   An internet connection (broadband is recommended; performance depends on connection speed).
   An iFit.com membership.


Note: The iFit® Module supports unsecured and secured (WEP, WPA, and WPA2) encryption.
It looks like the iFit module only has wireless "b", I know some old wireless "g" devices have problems connecting to the TG582n wireless "n" routers. So I can well imagine wireless "b" devices having the same issue.
The solution for old wireless "g" devices is to reduce the router from "n" to "b/g", so I'm guessing this may be worth a try in your case.
To disable wireless n in the router you need to use the telnet commands show here:
http://npr.me.uk/telnet.html#wirelessn
Look at the top of that page for help using telnet, shout up help.
Also go to the routers wireless settings page in the GUI and make sure "Broadcast Network Name" is enable. This is enabled by default but it's worth re-checking.
PS
Ignore port forwarding, that's a load of rubbish, you don't need that to make a wireless connection to your own router.
Also see:
https://ifit.zendesk.com/hc/en-us/articles/201800010-WiFi-Module-Connection-Troubleshooting
BarefootWandere
Dabbler
Posts: 12
Registered: 18-12-2014

Re: iFit Live Module won't connect to router and I need to be able to port forward??

thanks for suggestions.
I tried to disable n from router by copying the command in the link you gave me. In command prompt it said "wireless" is not recognised as an internal or external command. I got stuck here so if you have any ideas they'd be greatly appreciated Smiley
I inputed the following into command:
wireless ifconfig interop=802.11b/g
but it doesn't recognise it.
What my missing?Huh
BarefootWandere
Dabbler
Posts: 12
Registered: 18-12-2014

Re: iFit Live Module won't connect to router and I need to be able to port forward??

iFit told me to contact plusnet after trying various things and plusnet said i would need to open the port which ifit uses. I contacted iFit and asked them which port they used and they said:
Ports 80, 443, 4348
not sure if this helps but thought i'd mention it.
My head feels a bit fuzzy at mo so going to bed - will be back tomorrow.
Community Veteran
Posts: 1,829
Thanks: 93
Fixes: 5
Registered: 21-01-2013

Re: iFit Live Module won't connect to router and I need to be able to port forward??

Sorry those commands are for R8 firmware, I hadn't notice they had changed for R10 firmware.
The following commands should disable wireless n with R10 firmware.
Quote
To disable wireless n
wireless radio interop=802.11b/g
saveall

Quote
To return to wireless n (default)
wireless radio interop=802.11b/g/n
saveall
BarefootWandere
Dabbler
Posts: 12
Registered: 18-12-2014

Re: iFit Live Module won't connect to router and I need to be able to port forward??

Thanks npr the commands worked this time. I went into the router settings and now it states b/g only.
Unfortunately this hasn't worked as far as the iFit module is concerned. The timeout for connection continually appears saying the connection has failed. So, I reformatted the module, uninstalled adobeAir and the ifit install software and reinstalled them and started again - the module still doesn't connect with the network.
iFit say the module is compatible with WPA2-PSK as well as WEP and WPA2. The WPA2 won't enable in the router whereas the WPA2-PSK will (which is the one I'm now in) - is there a way I can configure the router to WPA2? would it be a possibility ? ? When I try to enable WPA2 and Apply a window pops up saying "Validation failed for (Radius IP) this ip address not valid for this field, connect and try again" - the following field is available for me to alter:
WPA Radius IP: 0.0.0.0
Any ideas would go down well at mo.
Thanks
BarefootWandere
Dabbler
Posts: 12
Registered: 18-12-2014

Re: iFit Live Module won't connect to router and I need to be able to port forward??

also...
can the ports be checked. iFit provided possible ports they use. Can they be checked/opened?
BarefootWandere
Dabbler
Posts: 12
Registered: 18-12-2014

Re: iFit Live Module won't connect to router and I need to be able to port forward??

I've just used the telnet command and discovered 4348 port is not open. Trouble is I don't know how to open it!!?? Any ideas?
pwatson
Rising Star
Posts: 2,468
Thanks: 8
Fixes: 1
Registered: 26-11-2012

Re: iFit Live Module won't connect to router and I need to be able to port forward??

I don't think the ports have anything to do with the issue - This is confusion introduced by someone in PN Support and they need a sharp kick and some retraining!
The wireless connection is the root of your issue and needs to be resolved first.  Check which wifi channel your router is using - Make sure it's not using channel 12 or 13.  Preferably set to to 1, 6 or 11.  Next, try (as an experiment) turning wireless security off completely and seeing if the device connects then.  If it does then you know the problem is to do with encryption rather than something more fundamental.
Community Veteran
Posts: 4,970
Thanks: 362
Fixes: 16
Registered: 10-06-2010

Re: iFit Live Module won't connect to router and I need to be able to port forward??

Something else to try is to change your wireless network name to something shorter than the default PlusnetWirelessXXXXXX.
Community Veteran
Posts: 1,829
Thanks: 93
Fixes: 5
Registered: 21-01-2013

Re: iFit Live Module won't connect to router and I need to be able to port forward??

I don't have a R10 firmware router handy at present to check, but looking at a R8 firmware Technicolor router you need to first select.
"Use WPA-PSK Encryption"  and  NOT  "Use WPA Encryption"
Then Under "WPA-PSK Version" you have the choice of selecting  WPA, WPA2 or WPA+WPA2
The only problem is you're now using wireless "b" and I don't think that allows WPA2.
You can open ports under the routers "game and application sharing". But as I understand it you're having problems connecting via wireless --- port forwarding has nothing to do with that.
I very much doubt you'll need port forwarding for the iFit to access the internet once you've got the wireless issue sorted -- there's no mention of it in the instructions I linked to above.
I expected disabling wireless "n" to work, don't know what to suggest at present other than trying different wireless channels -- try channel 1, 6 and 11 in turn.
Have you tried with the iFit closer to the router?
taras
Grafter
Posts: 226
Registered: 22-08-2008

Re: iFit Live Module won't connect to router and I need to be able to port forward??

The ports aren't needed be opened at as npr stated.
As ejs stated, shorten the ssid, and also try with no encryption and also those channels npr suggested ..
weystoner
Newbie
Posts: 5
Registered: 20-03-2008

Re: iFit Live Module won't connect to router and I need to be able to port forward??

I've just had a similar problem with my music streamers not connecting to the server.  Turned out to be McAfee firewall blocking the connection; I have turned this off and use Windows firewall instead, and all is good.  Any help?
Dave
BarefootWandere
Dabbler
Posts: 12
Registered: 18-12-2014

Re: iFit Live Module won't connect to router and I need to be able to port forward??

OK first of all thank you all for your suggestions.
Here's what I've tried so far:
Shortened the SSID the 3 characters from the default - tried to connect, no luck
Changed from chanel 6 to chanel 1, tried to connect, failed and then tried channel 11, still no joy so reverted back to channel 6.
I disabled the security settings and after 7 attempts it connected.  I managed to connect on WEP security settings before I posted here so I was sure it should connect with security disabled and it did. Eventually...
It's worth mentioning here that the process is long winded - I have to wait several minutes for the module to update even though it's already updated and on some occasions I have to reformat the module, uninstall software (inc. adobeAir which is used to run the install software) and start again otherwise it will just hang forever while looking for updates. Most of the time this will allow the updated to succeed but still won't connect on a secure network, i.e. WPA2-PSK. By the way the module is connected by usb when I try a connection attempt and the module is right next to the router.
I know I've already mentioned this but I'm running out of ideas now - iFit did say one of their ports they used was 4348 which when I ran telnet command said it couldn't connect. Is it possible this could be the problem, a long shot is better than nothing. I'll try it if I can find out how.
In the meantime any other suggestions would be welcome.
Thanks again for your efforts.
Community Veteran
Posts: 1,829
Thanks: 93
Fixes: 5
Registered: 21-01-2013

Re: iFit Live Module won't connect to router and I need to be able to port forward??

In desperation, try disconnecting the PC from the router (wifi or ethernet) while connected to the iFit via USB. Also try disabling the PC's firewall / security software while setting up the iFit.
Is there any DHCP settings available in the iFit?
If so set them to automatic or if it insists on a static IP address make sure it's within the routers pool range eg:
IP address 192.168.1.10
Subnet 255.255.255.0
Gateway 192.168.1.254
DNS  8.8.8.8
Note:
Port forwarding really is not the answer.
You do it with the routers "game and application sharing" but you can only port forward devices which are already connected to the router. That may sound like catch 22 but it's not really.
Good luck, please let us know if you find the answer.