cancel
Showing results for 
Search instead for 
Did you mean: 

Wierd Router issue?

scarp09
Newbie
Posts: 6
Registered: 17-05-2012

Wierd Router issue?

Hi,
I have a small network at home (2 PCs running Win10, a Mac Mini, a NAS and a couple of media devices). They are all on my home network, which is run by my Plusnet router ( a Sagemcom 2704N). I have Plusnet FTTC.
Here's the issue: If I switch my PC on before my wife's PC and check my Network, I can see all the devices on the network, but my wife can't. If, however, my wife's PC is switched on first, she can see everything on the network, but I can't. If I try to access the machines directly using their IP address, I can still make a connection to them (I can ping them or map a network drive), but they don't show us on the Windows "Network" view.
Seems a bit weird to me, and I'm assuming this is something to do with the Sagemcom router, since I never had these issues when I had ADSL and a Netgear router.
Any ideas?
Ta,
7 REPLIES
wisty
Pro
Posts: 456
Thanks: 59
Fixes: 4
Registered: 30-07-2007

Re: Wierd Router issue?

Welcome to the arcane world of Windows master browsers.
I can't help with a fix because I have never fully fixed this issue on my network. Sometimes it works, and sometimes it doesn't!!
What is happening is that the first computer that is switched on is declaring itself the master browser, but then refusing to share its lists of network resources with the second. There is also a report that the most recent major update to Windows 10 had a bug in this area.
http://mobility.forumsee.com/a/m/s/p12-10386-0986069--master-browser-bug-win-november-release.html
Not sure if it has been fixed.
Community Veteran
Posts: 26,686
Thanks: 910
Fixes: 10
Registered: 10-04-2007

Re: Wierd Router issue?

Set your PC's to have fixed IP addresses (outside of the router's DHCP range).
On each PC edit the hosts file (C:\Windows\System32\drivers\etc\hosts) and add your PCs with lines like:
192.168.1.25  YourPCname
192.168.1.26  WifesPCname
while you are at it I've added
192.168.1.254  TG582
so that I can access the router by name and that name appears in tracert's
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
scarp09
Newbie
Posts: 6
Registered: 17-05-2012

Re: Wierd Router issue?

Thanks to both!
I should have guessed it was a Windows issue. I'll probably assign foxed IP addresses as suggested.
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Wierd Router issue?

jelv, it's the 2704n, it generally won't allow assigning IP addresses outside the DHCP range, but assigning them inside the range I didn't find to be a problem.
Edit: And because it's the 2704n, you have to log into it using http://192.168.1.254/expert_user.html
Goto the >Advanced Setup >LAN page  see attached
Community Veteran
Posts: 26,686
Thanks: 910
Fixes: 10
Registered: 10-04-2007

Re: Wierd Router issue?

I should have been clearer: I wasn't suggesting assigning them in the router, they should be set in the network connection, IPv4 properties on the PCs themselves.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Wierd Router issue?

Ah. yep OK Wink
Doglet
Grafter
Posts: 38
Thanks: 3
Fixes: 1
Registered: 03-02-2016

Re: Wierd Router issue?

I sounds like a network descovery problem with the homegroup.
Maybe they're both on their own homegroup? (not sharing the same homegroup password)
I only have Windows 7 but it goes something like this...
On the machine that can see the network devices...
Right click the wifi bar on the bottom right
Open network and sharing center
Choose home group and sharing options
View or print the homegroup password.
On the machine that can't see the network...
Right click the wifi bar on the bottom right
Open network and sharing center
Choose home group and sharing options
Start the home group troubleshooter.
When prompted enter the homegroup password from the other machine.
Good luck.