cancel
Showing results for 
Search instead for 
Did you mean: 

Why is interleaving turned on for my connection?

artfulbodger
Rising Star
Posts: 51
Fixes: 1
Registered: ‎16-01-2015

Why is interleaving turned on for my connection?

Just checked my connection as it re-synced this afternoon - have found interleaving turned on (see below). Is there noise on the line, because as far as I knew we had a crystal clear and rock solid connection?
Stats recorded 21 Jul 2015 17:51:32
DSLAM/MSAN type:        BDCM:0xa44f / v0xa44f
Modem/router firmware:  AnnexA version - A2pv6C038m.d24j
DSL mode:              VDSL2 Profile 17a
Status:                Showtime
Uptime:                23 hours 2 min 43 sec
Resyncs:                0 (since 21 Jul 2015 17:48:5Cool

Downstream Upstream
Line attenuation (dB):  9.8 0.0
Signal attenuation (dB): Not monitored
Connection speed (kbps): 79360 19999
SNR margin (dB):        6.3 15.3
Power (dBm):            12.5 -5.2
Interleave depth:      8 1
INP:                    48.00 0
G.INP:                  Enabled
RSCorr/RS (%):          0.0001 0.0597
RSUnCorr/RS (%):        0.0000 0.0000
ES/hour:                0 0
12 REPLIES
Plusnet Help Team
Plusnet Help Team
Posts: 5,826
Thanks: 562
Fixes: 213
Registered: ‎01-01-2012

Re: Why is interleaving turned on for my connection?

Our testing is showing you have G.INP enabled rather then interleaving.
Your current profile is "0.128M-80M Downstream, Retransmission Low - 0.128M-20M Upstream, Error Protection Off"
If this post resolved your issue please click the 'This fixed my problem' button
 Matthew Wheeler
 Plusnet Help Team
elfish
Grafter
Posts: 235
Registered: ‎22-02-2009

Re: Why is interleaving turned on for my connection?

Yep, from the stats, you have G.INP enabled on the downstream and fastpath on the upstream.
With G.INP enabled. this will make your connection even better, as you will see less errors (ES/SES) but maintain the latency times of fastpath.
artfulbodger
Rising Star
Posts: 51
Fixes: 1
Registered: ‎16-01-2015

Re: Why is interleaving turned on for my connection?

Thanks Matthew. I knew G.INP was turned on since April this year. But how is the line still showing interleaving of 8?
artfulbodger
Rising Star
Posts: 51
Fixes: 1
Registered: ‎16-01-2015

Re: Why is interleaving turned on for my connection?

Blimey! Thanks elfish
Think I better go back to studying up about G.INP in more detail. Sorry and cheers.
Still can't understand what's preventing me from synching at the 80/29 I had for monthsHuh It's bugging me now. Wonder if there's a problem internally/master-socket?
englishrick
Grafter
Posts: 463
Registered: ‎14-02-2013

Re: Why is interleaving turned on for my connection?

Apparently its due to CROSSTALK.....lmfao... and NOTHING can be done!!!!!
[Moderator's note by Dick (Strat):  Full quote of preceding post removed, as per Forum Rule]
elfish
Grafter
Posts: 235
Registered: ‎22-02-2009

Re: Why is interleaving turned on for my connection?

Quote from: artfulbodger
Thanks Matthew. I knew G.INP was turned on since April this year. But how is the line still showing interleaving of 8?

The 'interleaver depth' still applies when G.INP is enabled.
What's important is that the 'delay' is shown as being 0.
As for you not sync'ing at full rate, that could be down to many factors, crosstalk being one.  Wink Or the time of day when the resync occurred, what the weather conditions were like, or if interference was present.
artfulbodger
Rising Star
Posts: 51
Fixes: 1
Registered: ‎16-01-2015

Re: Why is interleaving turned on for my connection?

Elfish, if I were to do a forced re-synch what time of the time would you recommend I do it? I've heard early mornings is best, unless it doesn't matter anymore.
Community Veteran
Posts: 1,412
Thanks: 4
Registered: ‎29-01-2009

Re: Why is interleaving turned on for my connection?

Quote from: artfulbodger
Thanks Matthew. I knew G.INP was turned on since April this year. But how is the line still showing interleaving of 8?

Old-style DLM intervention would turn on very high levels of interleaving (not just higher depth, but higher block size, or "width") and FEC protection.
Under new-style "retransmission", G.INP is turned on, but both interleaving and FEC protection stay in use. However, the settings are much less aggresive: interleaving delay amounts to around 0.2ms instead of 8 or 16ms, and the FEC overhead amounts to around 5% of bandwidth instead of 20%.
Quote from: artfulbodger
Still can't understand what's preventing me from synching at the 80/29 I had for monthsHuh It's bugging me now.

Don't let it bug you, it isn't worth it.
VDSL2 is heavily susceptible to crosstalk - which is noise introduced by other FTTC subscribers. This means that your speed can drop whenever new subscribers are added, but the impact is highly random; In practice, you will lose speed in fits and bursts over a couple of years.
When BT Wholesale's DSL checker provides you a range of estimated speeds, they don't just mean that your speed will end up in that range on day 1 and you keep that speed forever more. What they mean is that your speed will vary within those limits over time.
Over 2 years, my line had attainable speeds that dropped from around 90/25 to 78/22. Whenever DLM intervened, that end speed would drop to 72/20.
Vectoring is the proper solution, if/when BT choose to deploy it.
Quote from: artfulbodger
if I were to do a forced re-synch what time of the time would you recommend I do it? I've heard early mornings is best, unless it doesn't matter anymore.

If you want to be sure, it would be when your SNR levels are at your highest. Here that period can start anytime between midnight and 4am, and end between 7am and 10am.
Plusnet Customer
Using FTTC since 2011. Currently on 80/20 Unlimited Fibre Extra.
artfulbodger
Rising Star
Posts: 51
Fixes: 1
Registered: ‎16-01-2015

Re: Why is interleaving turned on for my connection?

Thanks wwwombat. So switch off everything at the mains and wait for half an hour? Or do a power down via the router, then switch off at the mains?
artfulbodger
Rising Star
Posts: 51
Fixes: 1
Registered: ‎16-01-2015

Re: Why is interleaving turned on for my connection?

Anyone with any advice on whether to do a controlled power down, or just simply switch off at the mains for a forced re-sync?
jafreer
Aspiring Pro
Posts: 844
Thanks: 54
Registered: ‎13-10-2012

Re: Why is interleaving turned on for my connection?

I think most people recommend disconnecting the PPPoE connection on the router (log in to router and hit disconnect). Once that is done, switch off the modem. Some say wait 30 minutes to prevent DLM from making any changes to your line. My experience is that for a modem power down and power backup, I have never had a problem. If you decide not to wait the 30 minutes, I suggest waiting at least several minutes with the modem powered down before applying power again.
Once the modem is back in sync, you may have to log into your router and reconnect (or it may be automatic).
Good luck.
Community Veteran
Posts: 1,412
Thanks: 4
Registered: ‎29-01-2009

Re: Why is interleaving turned on for my connection?

That'll do it. The 30 minute thing seems to be an abundance of caution for days when you expect to make a few outages.
I had a day of power outages recently, with an RCCB playing up. I went through quite a few re-syncs (at least 5) before DLM intervened; then a few more re-syncs which caused it to get worse.
Plusnet Customer
Using FTTC since 2011. Currently on 80/20 Unlimited Fibre Extra.