cancel
Showing results for 
Search instead for 
Did you mean: 

Vastly different speeds on different laptops

msowden22
Dabbler
Posts: 11
Registered: 02-03-2016

Vastly different speeds on different laptops

Hi! I'm getting vastly different upload speeds when I connect to my plusnet One Hub;  52mbps on one laptop, 14mbps on the other when placed next to each other.
The laptops are both roughly the same age. I cannot figure out what the issue is - any suggestions?Huh
Thanks! Mark.
Speed test data
Download speed achieved during the test was - 13.72 Mbps
For your connection, the acceptable range of speeds is  40 Mbps-61.55 Mbps .
Upload speed achieved during the test was - 1.95Mbps
Upstream Rate IP profile on your line is - 20 Mbps
24 REPLIES
Thetwohoughs
Grafter
Posts: 55
Registered: 05-12-2015

Re: Vastly different speeds on different laptops

Are you connected via Ethernet or Wireless?
msowden22
Dabbler
Posts: 11
Registered: 02-03-2016

Re: Vastly different speeds on different laptops

Wireless
Thetwohoughs
Grafter
Posts: 55
Registered: 05-12-2015

Re: Vastly different speeds on different laptops

Ah, it all depends on what Wireless internals are in the Laptops then.
Have you tried checking the connection speed via the network section within windows?
Here's a decent guide >> http://www.linksys.com/id/support-article?articleNum=136766
Let me know what you find please  Smiley
msowden22
Dabbler
Posts: 11
Registered: 02-03-2016

Re: Vastly different speeds on different laptops

It says the wireless connection speed is 54 mbps
scottymc
Grafter
Posts: 224
Thanks: 5
Registered: 04-02-2015

Re: Vastly different speeds on different laptops

Thats your connection speed from the pc to the hub.
Not your connection speed.
Hub to the exchange..
Your speed test shows 13.72...  If I was you I'd try a speed test , but with both pc's connected via Ethernet cable
pwatson
Rising Star
Posts: 2,468
Thanks: 8
Fixes: 1
Registered: 26-11-2012

Re: Vastly different speeds on different laptops

You won't get more than around 22Mbps through a 802.11g 54Mbps wireless connection so although 14Mbps is a little low it's not entirely unexpected.
What's more of a puzzle is the other laptop getting 52Mbps when, based on your 2Mbps upload speed, you appear to be on a 40Mbps down product?
As others have said, you need to test via a wired connection to check your broadband speed.
msowden22
Dabbler
Posts: 11
Registered: 02-03-2016

Re: Vastly different speeds on different laptops

Morning everyone - cheers for your support.
Just to clarify my package is plusnet unlimited extra (up to 78mbps) - I don't think it is a problem with the service to my hub, it seems to be a problem with wifi to one of my two laptops.
I've done speedtests for wired and wireless on both laptops:
Speed test data using wired connection on the problematic laptop
Download speed achieved during the test was - 47.05 Mbps
For your connection, the acceptable range of speeds is  40 Mbps-61.55 Mbps .
Upload speed achieved during the test was - 1.21Mbps
Upstream Rate IP profile on your line is - 20 Mbps
Speed test data using wireless connection on the problematic laptop
Download speed achieved during the test was - 13.72 Mbps
For your connection, the acceptable range of speeds is  40 Mbps-61.55 Mbps .
Upload speed achieved during the test was - 1.95Mbps
Upstream Rate IP profile on your line is - 20 Mbps
Speed test data using wired connection on the other laptop
Download speed achieved during the test was - 59.41 Mbps
For your connection, the acceptable range of speeds is  40 Mbps-61.55 Mbps .
Upload speed achieved during the test was - 12.84 Mbps
Upstream Rate IP profile on your line is - 20 Mbps
Speed test data using wireless connection on the other laptop
Download speed achieved during the test was - 59.40 Mbps
For your connection, the acceptable range of speeds is  40 Mbps-61.55 Mbps .
Upload speed achieved during the test was - 10.82 Mbps
Upstream Rate IP profile on your line is - 20 Mbps
scottymc
Grafter
Posts: 224
Thanks: 5
Registered: 04-02-2015

Re: Vastly different speeds on different laptops

Nothing wrong with the second laptop on WiFi its more or less the the same as wired...
Looks like the first laptop has the issues.....
msowden22
Dabbler
Posts: 11
Registered: 02-03-2016

Re: Vastly different speeds on different laptops

Yes, I know - that's why I'm asking for help.
I'm hoping someone has an idea what the problem is and how I can rectify it!
I've tried asking plusnet support - they don't have a clue - told me to ask an 'expert' to look at it.
By the way, there was no discrepancy between the speeds these laptops got over wifi when using the Technicolor hub previously supplied by plusnet for my smaller fibre package.
So... any 'experts' out there?!  Tongue
Andrue
Pro
Posts: 775
Thanks: 90
Fixes: 1
Registered: 12-01-2015

Re: Vastly different speeds on different laptops

Quote from: scottymc
Nothing wrong with the second laptop
Well you say that but I'm not impressed by the upload speed. It's just that my 67Mb/s connection gets me around 18.5Mb/s upload. Do you really lose that amount of upload when connected at 60Mb/s?
scottymc
Grafter
Posts: 224
Thanks: 5
Registered: 04-02-2015

Re: Vastly different speeds on different laptops

Are both laptops running the same OS have the same service packs are you using the same browser on both.... I've read Firefox can have problems with speedtests...
There are so many variables ...
I get 68meg and get max upload so maybe your upload is a little low.....
msowden22
Dabbler
Posts: 11
Registered: 02-03-2016

Re: Vastly different speeds on different laptops

Yes everything is set up the same.
Surely the fact that it was fine before the hub upgrade suggests it is a software/ setting/ compatibility issue?
Andrue
Pro
Posts: 775
Thanks: 90
Fixes: 1
Registered: 12-01-2015

Re: Vastly different speeds on different laptops

Quote from: msowden22
Surely the fact that it was fine before the hub upgrade suggests it is a software/ setting/ compatibility issue?
Yup. It does sound like some kind of hub related issue.
msowden22
Dabbler
Posts: 11
Registered: 02-03-2016

Re: Vastly different speeds on different laptops

I have tried connecting a friend's laptop - similar issues:
Speed test data using wired connection on friends laptop
Download speed achieved during the test was - 49.23 Mbps
For your connection, the acceptable range of speeds is  40 Mbps-61.55 Mbps .
Upload speed achieved during the test was - 2.31 Mbps
Upstream Rate IP profile on your line is - 20 Mbps
Speed test data using wireless connection on friends laptop
Download speed achieved during the test was - 14.19 Mbps
For your connection, the acceptable range of speeds is  40 Mbps-61.55 Mbps .
Upload speed achieved during the test was - 2..01 Mbps
Upstream Rate IP profile on your line is - 20 Mbps
There is clearly a compatibility issue with the new hub.
I'm angry that the plusnet support have just fobbed me off - telling me to 'see an expert' is a joke.
A major broadband company should have 'experts' working for them!!
Is there staff on here from plusnet that can give me further support?