cancel
Showing results for 
Search instead for 
Did you mean: 

Upgraded fibre to 76mb, still slow speeds!

daveprosseruk
Dabbler
Posts: 16
Registered: 13-10-2016

Upgraded fibre to 76mb, still slow speeds!

Hi Plusnet,

 

I recently upgraded my service from the 38mb fibre to the 76mb fibre, however, I'm experiencing slow download speeds of around 25mb, similar to that of my old service. My upload speed has increased, so I can tell that the new service has been enabled on my account. I have ran the BT speed tests and have posted the results below. I've also noticed that my line seems to slow down more in the evening to a measly 2-5mb. 

 

Screen Shot 2017-07-30 at 10.59.59.png

3 REPLIES
daveprosseruk
Dabbler
Posts: 16
Registered: 13-10-2016

Re: Upgraded fibre to 76mb, still slow speeds!

Attempted the ' further diagnostics' via BT speed test, getting this after I enter the username into my router. Any help anybody? 

 

Screen Shot 2017-07-30 at 11.09.08.png

Community Veteran
Posts: 38,460
Thanks: 1,027
Fixes: 62
Registered: 15-06-2007

Re: Upgraded fibre to 76mb, still slow speeds!

If those tests are wired and are similar to before you upgraded it would indicate a problem as you are in sync at a much higher speed

Have you tried reporting a speed fault at https://faults.plus.net

Although this may indicate part of the problem https://portal.plus.net/my.html?action=data_transfer_speed

Plusnet Help Team
Plusnet Help Team
Posts: 5,056
Thanks: 445
Fixes: 161
Registered: 01-01-2012

Re: Upgraded fibre to 76mb, still slow speeds!

Sorry to hear your speeds hasn't increased.

I can see you have a fault open regarding this and our Faults team will be in touch as soon as possible.

If this post resolved your issue please click the 'This fixed my problem' button
 Matthew Wheeler
 Plusnet Help Team