cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade yesterday - no connection since!

kdjmonaghan
Newbie
Posts: 2
Registered: 30-06-2016

Upgrade yesterday - no connection since!

I require a working internet connection at home to do part of my job - the fact the service is having issues and possibly having to wait until next week to have a resolve is very inconvenient for me and can seriously damage my monthly income.

The "upgrade" process to Fibre has been a joke thus far - I ordered Fibre on the 16th when it was shown to be "available" then had confirmation from Open Reach that this was not the case and the cabinet was full and I would receive a call on the 30th of June regarding my order if it can be pushed through.

Earlier last week I received and e-mail to say that my "Order was Complete" (no, it wasn't, I didn't have a Plusnet One router and I didn't know when my installation date was) which required a phone call to even get the router dispatched and I was told that OpenReach had confirmed installation date of the 29th.

I've not had any form of notification from OpenReach, other than word of mouth from Plusnet which at this point is very questionable due to the fact I've had to phone up to even get a router from them that I ordered and paid for weeks beforehand.

My DSL line I upgraded from now no longer works which means I have zero internet connection in my house until this is resolved.

Given the installation date was the Wednesday, 29th of June 2016 and the fault has been reported and being looked into on Thursday, 30th of June 2016 (after I phoned up about it they're looking into it, there is no process to check the lines after installation if you can magically check faults in the line?! Absurd and frankly poor customer care/quality checking!) I could be waiting until NEXT WEEK to even have a connection in my house again as the process could take up to 72 hours! No doubt even longer if they have to contact OpenReach to get someone to look at it!

I'm paying for a product that doesn't work, not only that but I'm paying money for a product that is supposed to (in part, I require the internet for work) enable me to do my job to pay for the product in the first place!

This process has been very disappointing, stressful and extremely frustrating and quite frankly is shocking given how many times I have had to call up about things that -then- get looked into by engineers to be told I could be waiting possibly a week to have a resolve.

3 REPLIES
Moderator
Moderator
Posts: 18,511
Thanks: 1,806
Fixes: 222
Registered: 11-01-2008

Re: Upgrade yesterday - no connection since!

Perhaps if you need it for work you should have picked a business product with enhanced care?

Customer / Moderator / If it helped click the thumb / If it fixed it click 'This fixed my problem'

Plusnet Help Team
Plusnet Help Team
Posts: 5,423
Thanks: 503
Fixes: 187
Registered: 01-01-2012

Re: Upgrade yesterday - no connection since!

Sorry to hear about your issues.

I've asked our Faults team to get this looked into.

If this post resolved your issue please click the 'This fixed my problem' button
 Matthew Wheeler
 Plusnet Help Team
kdjmonaghan
Newbie
Posts: 2
Registered: 30-06-2016

Re: Upgrade yesterday - no connection since!

Thanks for the suggestion, but no - I specifically picked the cheaper, normal, option for the following reasons:

 

 

- I travel to clients a lot and work with them (software developer)

- I'm hardly in during the week

- The speeds of a standard line even at minimum are enough to produce the work I do, so long as the upload speed is there to do so (>5MB minimum)

 

I'm in the house normally from 7pm>7am, meaning, the internet is required for these hours which reduces the need of the dedicated business line option, not only that, but this is a flat, I do some work from home between these hours and sometimes full days during the week depending on what my clients require.

 

Paying for a dedicated line wouldn't be worth it with the money and the faults I've described above should be addressed easily and have been checked on the day during installation.

 

Appreciate your reply regardless, but I did consider the option.