cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to RDP to Port 3389 from outside network

mterrey
Hooked
Posts: 5
Thanks: 1
Registered: ‎24-09-2017

Unable to RDP to Port 3389 from outside network

Hi All,

 

I have RDP'd to 192.168.1.3:3389 fine from another laptop on the same network.  However, when I try the same thing with my external IP address it isn't working.  I have set up port forwarding on my r7000 (Advanced Tomato) for both TCP/UDP for port 3389 - and pointed it at 192.168.1.3.  It seems as though the port forwarding is being ignored.  If this port can't be opened - does anyone know some that can?

 

Thanks,

Mark

5 REPLIES
Dahnak
Dabbler
Posts: 17
Thanks: 3
Registered: ‎08-05-2018

Re: Unable to RDP to Port 3389 from outside network

have you made sure that the extra plus.net "broadband firewall" is set to allow, as by default common ports are blocked. go to https://portal.plus.net/my.html?action=firewall to check

 

D

Browni
Aspiring Hero
Posts: 2,299
Thanks: 790
Fixes: 47
Registered: ‎02-03-2016

Re: Unable to RDP to Port 3389 from outside network

Is the Plusnet Firewall blocking the connection?

(Plusnet login reqd for the above link)

eta: 2nd again!

I must have been really bad in a previous life as this was my 3rd ISP in a row that used lithium.
Now you're stuck with me because my new ISP doesn't run a forum Cheesy
mterrey
Hooked
Posts: 5
Thanks: 1
Registered: ‎24-09-2017

Re: Unable to RDP to Port 3389 from outside network

Hi Dahnak,

That did sound very promising! Unfortunately that setting seems to be off, I did try setting it to Low then back off again - still no joy though. It's almost as if all ports are blocked. I tried turning my firewalls off temporarily but with no effect - shouldn't be that anyway as I was able to RDP from within the network.

Thanks,

Mark

mterrey
Hooked
Posts: 5
Thanks: 1
Registered: ‎24-09-2017

Re: Unable to RDP to Port 3389 from outside network

Thanks Browni Smiley

Dahnak
Dabbler
Posts: 17
Thanks: 3
Registered: ‎08-05-2018

Re: Unable to RDP to Port 3389 from outside network

Hi Mark,

 

 

I have done a little bit of poking around, as logic says it should work.

 

After looking at the firewall rules for RDP on windows 10, I noticed the following setting on the entry for both remote desktop on UDP and TCP, in the advanced tab, there is an option called "Edge Traversal" which is turned on by default.  This will block any RDP connections from outside your network from successfully connecting. presumably you will need to change this on both UDP and TCP rulesRDP.JPG

 

just be aware of the security implications from allowing full internet RDP Smiley

 

Darren