cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble loading website

grahameys
Dabbler
Posts: 16
Registered: 25-02-2014

Trouble loading website

Hey there,
Up until recently, I have been able to connec to http://bt.etree.org (a legal torrent tracker for live music recordings with artist permission) but for the past few weeks, it just times out. I have tried to connect to it via my father's ADSL (which is also Plusnet) with the same problems. However, I am able to connect to the site just fine via my phones 3G and a multitude of other ISPs too. I can also connect via my Plusnet connection  if I use a proxy loading website.
I am hoping this is a simple routing issue on Plusnet's side of things. Can you guys look into this?
Thanks
6 REPLIES
DamBuilder
Grafter
Posts: 57
Registered: 12-09-2015

Re: Trouble loading website

Just tried your link and it works fine for me.
Andrue
Pro
Posts: 775
Thanks: 90
Fixes: 1
Registered: 12-01-2015

Re: Trouble loading website

Community Veteran
Posts: 5,164
Thanks: 478
Fixes: 20
Registered: 10-06-2010

Re: Trouble loading website

Probably would work if you change your DNS servers to Google DNS or OpenDNS.
[tt]$ dig @8.8.8.8 bt.etree.org
; <<>> DiG 9.10.3-RedHat-9.10.3-1.fc23 <<>> @8.8.8.8 bt.etree.org
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38198
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1
;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;bt.etree.org. IN A
;; ANSWER SECTION:
bt.etree.org. 435 IN CNAME etree.ibiblio.org.
etree.ibiblio.org. 11295 IN A 152.19.134.46
;; Query time: 41 msec
;; SERVER: 8.8.8.8#53(8.8.8.Cool
;; WHEN: Mon Oct 12 16:14:14 BST 2015
;; MSG SIZE  rcvd: 85[/tt]
Plusnet's DNS servers are returning a highly questionable IP address of 127.0.0.1 (the loop back address for your own computer) for bt.etree.org
[tt]$ dig @212.159.6.9 bt.etree.org
; <<>> DiG 9.10.3-RedHat-9.10.3-1.fc23 <<>> @212.159.6.9 bt.etree.org
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 50422
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;bt.etree.org. IN A
;; ANSWER SECTION:
bt.etree.org. 3600 IN A 127.0.0.1
;; Query time: 16 msec
;; SERVER: 212.159.6.9#53(212.159.6.9)
;; WHEN: Mon Oct 12 16:16:05 BST 2015
;; MSG SIZE  rcvd: 57[/tt]
The "time to live" value of 3600 seconds returned by Plusnet's DNS servers does not decrease as it does for a normal cached result. So it appears Plusnet DNS servers are deliberately returning a bogus result.
DamBuilder
Grafter
Posts: 57
Registered: 12-09-2015

Re: Trouble loading website

Quote from: ejs
Probably would work if you change your DNS servers to Google DNS or OpenDNS.

Ah good point. I don't use PN DNS.
grahameys
Dabbler
Posts: 16
Registered: 25-02-2014

Re: Trouble loading website

Quote from: ejs
Probably would work if you change your DNS servers to Google DNS or OpenDNS.
[tt]$ dig @8.8.8.8 bt.etree.org
; <<>> DiG 9.10.3-RedHat-9.10.3-1.fc23 <<>> @8.8.8.8 bt.etree.org
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38198
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1
;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;bt.etree.org. IN A
;; ANSWER SECTION:
bt.etree.org. 435 IN CNAME etree.ibiblio.org.
etree.ibiblio.org. 11295 IN A 152.19.134.46
;; Query time: 41 msec
;; SERVER: 8.8.8.8#53(8.8.8.Cool
;; WHEN: Mon Oct 12 16:14:14 BST 2015
;; MSG SIZE  rcvd: 85[/tt]
Plusnet's DNS servers are returning a highly questionable IP address of 127.0.0.1 (the loop back address for your own computer) for bt.etree.org
[tt]$ dig @212.159.6.9 bt.etree.org
; <<>> DiG 9.10.3-RedHat-9.10.3-1.fc23 <<>> @212.159.6.9 bt.etree.org
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 50422
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;bt.etree.org. IN A
;; ANSWER SECTION:
bt.etree.org. 3600 IN A 127.0.0.1
;; Query time: 16 msec
;; SERVER: 212.159.6.9#53(212.159.6.9)
;; WHEN: Mon Oct 12 16:16:05 BST 2015
;; MSG SIZE  rcvd: 57[/tt]
The "time to live" value of 3600 seconds returned by Plusnet's DNS servers does not decrease as it does for a normal cached result. So it appears Plusnet DNS servers are deliberately returning a bogus result.

You were spot on, thanks! All sorted now!!
Community Gaffer
Community Gaffer
Posts: 13,413
Thanks: 1,178
Fixes: 91
Registered: 04-04-2007

Re: Trouble loading website

Quote from: ejs
Plusnet's DNS servers are returning a highly questionable IP address of 127.0.0.1

Very odd. Particularly when a DNS trace returns the correct details Huh
I'll see if I can get somebody to take a look (ref: 88422).

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵