Showing results for 
Search instead for 
Did you mean: 


Posts: 2
Registered: ‎21-11-2019


Hello, found this on the forum:
Plusnet does not throttle internet connections unless your account is in failed billing.
As well in the docs it says the Unlimited Fibre (my option) should not have any prioritisation in place.

I decided to switch (this week deployed) from Virgin due to upload speeds but there is a problem.

I tried to download raspberry pi image from my SSH server and average download speed was 500KB/s which is around 25% what my upload is. I tried few times and at the start it has 2MB/s but then after 30MB of data it goes again to same (indicating that speed is there but then something is decreasing it). Speed test indicates that speed is there (17Mb). I have done some other testing (SSH through other ports) and it is seems that there is a throttling applied to some of them at Plusnet side. Is this correct? I am using port 3333 in this case, tested with others (same protocol) - and I am getting different speeds depending on the port used ... clearly a traffic speed shaping.

If this is correct then I am getting my service cancelled as advertising on 17Mb upload and then reducing the speed 4Mb seems to me quite unfair.


Posts: 2
Registered: ‎21-11-2019

Throttling ssh

As the start info I have seen other posts on forum regarding this but with no answer.
I switched from Virgin as static ip and upload speeds convinced me (or maybe not now after today's discovery) . The issue I got is that I tried for the first time to download a big file from ssh server at home and it seems traffic management is bringing my transfer to 500KB/s. I tried standard 22 port and one of not default ones. Funny enough I found some workaround to bypass this restriction however the whole idea of advertising the service with 17Mb upload speed while in fact it is around 4Mb only seems to me like a scam. It should say speed is for certain services only...

Anybody knows how traffic speed is being managed or maybe it will improve at some point as this was only installed few days ago?
Tags (3)
Posts: 28,304
Thanks: 6,177
Fixes: 1,443
Registered: ‎11-01-2008

Re: Throttling ssh

Moderators Note

Topic has been released from spam filter and merged in with another from same OP.

Customer / Moderator
If it helped click the thumb
If it fixed it click 'This fixed my problem'
Plusnet Help Team
Plusnet Help Team
Posts: 24,597
Thanks: 8,942
Fixes: 1,432
Registered: ‎21-04-2017

Re: Throttling

Thanks for getting in touch @daski I'm sorry to see you're experiencing speed problems. I can firstly confirm we've not had traffic management on our network for unlimited residential packages since 29th June 2017. Although even when we did have this, it was more traffic prioritisation within your household, there's more information Here if you're interested.

I've tested your line and as shown from the test results below I can see your router is getting a downstream line speed of 74mbps and an upstream line speed of 18mbps. There's also no congestion seen at the exchange.

GEA Test Detail
Circuit ID NA Service ID [redacted]
Test Outcome Pass
Test Outcome Code GTC_FTTC_SERVICE_0000
Description GEA service test completed and no fault found .
Main Fault Location OK
Sync Status In Sync
Downstream Speed 74.1 Mbps
Upstream Speed 18.1 Mbps
Appointment Required N
Fault Report Advised N
NTE Power Status PowerOn
Voice Line Test Result Pass
Bridge Tap Not Detected
Radio Frequency Ingress Not Detected
Repetitive Electrical Impulse Noise Not Detected
Cross Talk Not Detected
Estimated Line Length In Metres 472.8
Upstream Rate Assessment Reasonable
Downstream Rate Assessment Very Good
Interference Pattern Regular Interference Observed on Week Days
Service Impact No Impact Observed
Interference Duration Longest Occurrence From05:00to07:15
Interference Location Other
Interference Observed In Days 3
Home Wiring Problem Not Detected
Technology VDSL
Current 15Min Bin Retrains 0
Last 15Min Bin Retrains 0
DP Type External
Profile Name 0.128M-80M Downstream, Interleaving Low - 0.128M-20M Upstream, Error Protection Off
Time Stamp 2019-11-19T15:15:00
Parameters MIN MAX AVG
Down Stream Line Rate 62.4 Mbps 74.2 Mbps 63.4 Mbps
Up Stream Line Rate 18.1 Mbps 18.3 Mbps 18.3 Mbps
Up Time 860.0 Sec 900.0 Sec 899.8 Sec
Retrains 0.0 1.0 0.0
Current and Last 15 Minute Bin Performance
Parameters Last Traffic Count(Upto 15 mins) Current Traffic Count(Upto 15 mins)
Start Time Stamp 2019-11-22T12:57:13Z 2019-11-22T13:12:13Z
Ingress Code Violation 4 0
Egress Code Violation 0 0
Errored Seconds 0 0
Severely Errored Seconds 0 0
Unavailable Seconds 0 0

If you're getting an upload speed of 17mbps not through your SSH server, this should in theory indicate there are no issues with the broadband signal going over the Openreach and BT infrastructure and our network. 

Are you using your own router or the Hub One we've provided? If you're using your own, do you have any Quality of Service(QoS) settings enabled which may be limiting your throughput?

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team