cancel
Showing results for 
Search instead for 
Did you mean: 

TP-Link TD-W9980 modem/router DNS server not working

bbslaw
Newbie
Posts: 6
Registered: 27-05-2015

TP-Link TD-W9980 modem/router DNS server not working

Hi
I recently moved to PN on fibre and installed my TD-W9980 router straightaway. It all worked fine (I upgraded the firmware to the Dec 2014 release when I got it, so the PN settings were in there) for a couple of months. Then a couple of weeks ago, I lost the internet. The DSL light is on, but no internet light. The problem seems to be with the DNS lookup - it won't resolve the DNS server. I have installed the PN router coupled to the OpenReach modem and everything works fine. However, I want to go back to the TP-Link modem/router because: the wifi signal from the PN router isn't very good; I paid a load of money for the TP-Link and want to use it; and it uses one less plug than the router/modem combo.
I'd be grateful for any advice for a tech/internet noob on how to rectify this problem. After research I have tried manually inputting the PN DNS settings (212.159.13.49/212.159.13.50) as well as the Google ones (8.8.8.8/8.8.4.4), but this made no difference.
Any advice gratefully received!
Cheers
15 REPLIES
Community Veteran
Posts: 6,651
Thanks: 230
Fixes: 16
Registered: 16-02-2009

Re: TP-Link TD-W9980 modem/router DNS server not working

Strange, can you go to the Diagnostic tab (down the bottom of the left hand column)
Try the 2 tests there.
This is what I get from the 1st test:
Quote

Test Internet surfing
  Test xDSL Synchronization Pass
  ATM OAM Segment Ping Pass
  ATM OAM end to end Ping Pass
  Test PPP Server connection Pass
  Test authentication with ISP Pass
  Test the assigned IP address Pass
  Ping default gateway Pass
  Ping primary Domain Name Server Pass
  Test DNS Root Pass
  Network Connection Status Inspect(NCSI) Pass

Also check the DHCP server settings:
Make sure it is
1. Enabled
2. has NO dns servers set (or the PN/Google ones)
From your client:
Open a command prompt: (cmd on windows terminal on Linux don't know mac)
enter:
nslookup <enter>
server <enter>
(this should show the dns servers set in the DHCP)
bbc.co.uk <enter>
(this should show something like this)
> bbc.co.uk
Server: 192.168.1.68
Address: 192.168.1.68#53
Non-authoritative answer:
Name: bbc.co.uk
Address: 212.58.244.18
Name: bbc.co.uk
Address: 212.58.246.103
Name: bbc.co.uk
Address: 212.58.246.104
Name: bbc.co.uk
Address: 212.58.244.20
>

Your dns server will be different. NB the <enter> are the enter/return key not a command.
If your client isn't showing the above or similar try:
> server 8.8.8.8
Default server: 8.8.8.8
Address: 8.8.8.8#53
> bbc.co.uk
Server: 8.8.8.8
Address: 8.8.8.8#53
Non-authoritative answer:
Name: bbc.co.uk
Address: 212.58.246.103
Name: bbc.co.uk
Address: 212.58.244.20
Name: bbc.co.uk
Address: 212.58.246.104
Name: bbc.co.uk
Address: 212.58.244.18
>

This sets Google to be the dns server for the next queries, then tries bbc.co.uk again.
PeeGee
Aspiring Pro
Posts: 1,081
Thanks: 45
Fixes: 3
Registered: 05-04-2009

Re: TP-Link TD-W9980 modem/router DNS server not working

Looking at the manual, my bet is on the username/password needing to be re-input Roll eyes
Phil
Plusnet Fibre (Sep 2014), Essentials (Feb 2013); ADSL (Apr 2009); Customer since Jan 2004 (on 28kb dial-up)
Using a TP-Link TD-W9980 modem-router.
Community Veteran
Posts: 6,651
Thanks: 230
Fixes: 16
Registered: 16-02-2009

Re: TP-Link TD-W9980 modem/router DNS server not working

Given that it WAS connected the password shouldn't have changed.
PeeGee
Aspiring Pro
Posts: 1,081
Thanks: 45
Fixes: 3
Registered: 05-04-2009

Re: TP-Link TD-W9980 modem/router DNS server not working

Alternatively, given that it was connected and now shows signs of not being so, something that was correct now has changed.
However, we have not been told if there is a connected session or not and the internet light often (usually or almost invariably?) indicates the session status not DNS capability.
Phil
Plusnet Fibre (Sep 2014), Essentials (Feb 2013); ADSL (Apr 2009); Customer since Jan 2004 (on 28kb dial-up)
Using a TP-Link TD-W9980 modem-router.
bbslaw
Newbie
Posts: 6
Registered: 27-05-2015

Re: TP-Link TD-W9980 modem/router DNS server not working

Thanks for your advice so far.
I have factory reset the modem multiple times and have also set it up from the start multiple times, so it's not a missing username/password. I have also tried using the TP-Link as a router connected to the OpenReach modem, but that came up with the same result.
I'll try your suggestions tonight. Unfortunately switching it over is a bit of a pain as everything is behind the TV cabinet, and if what I try doesn't work I don't have any internet access (except on the phone) to see what next steps to take until I set the PN router back up.
Community Veteran
Posts: 1,829
Thanks: 93
Fixes: 5
Registered: 21-01-2013

Re: TP-Link TD-W9980 modem/router DNS server not working

Have you looked in the routers log, see if there's any clues in there.
bbslaw
Newbie
Posts: 6
Registered: 27-05-2015

Re: TP-Link TD-W9980 modem/router DNS server not working

Thanks for the suggestion npr; don't know how to do that though. I tried the diagnostic and 'Test authentication with ISP' failed in both tests.
These are the LAN settings on the router: And the Basic status settings: Hopefully they give someone with more idea than me a clue as to what is going on.
Cheers
Community Veteran
Posts: 6,651
Thanks: 230
Fixes: 16
Registered: 16-02-2009

Re: TP-Link TD-W9980 modem/router DNS server not working

Ok given what is shown then it hasn't managed to do a ppp connection. Have a look at the logs and see if the ppp session is failing on password/name.
Treble check the name is @plusdsl.net and the password is C0rrect.
PeeGee
Aspiring Pro
Posts: 1,081
Thanks: 45
Fixes: 3
Registered: 05-04-2009

Re: TP-Link TD-W9980 modem/router DNS server not working

If you haven't found it, the log is via "system tools -> system log" Smiley
Phil
Plusnet Fibre (Sep 2014), Essentials (Feb 2013); ADSL (Apr 2009); Customer since Jan 2004 (on 28kb dial-up)
Using a TP-Link TD-W9980 modem-router.
bbslaw
Newbie
Posts: 6
Registered: 27-05-2015

Re: TP-Link TD-W9980 modem/router DNS server not working

Cheers, I'll have a look at the log tonight. I am not aware that I've consciously changed the default password for the DSL, but I did change my account password, so perhaps I need to update the password on the modem/router. However, there was a significant period of time between  changing the account password and the modem dying. Is it possible that it only checks in every few weeks?
Thanks for your help. I'll be embarrassed if it is the password after all this... Embarrassed
bbslaw
Newbie
Posts: 6
Registered: 27-05-2015

Re: TP-Link TD-W9980 modem/router DNS server not working

Just had a look at another link someone posted http://forum.kitz.co.uk/index.php/topic,14436.0.html and there is a big red note next to the W9980 'NO G.INP unless use beta f/w'. I also notice there is a firmware link on the TP-Link website that 'Fixed the bug that the speed dropped on the BT line of UK when G.INP was enabled'. My problem first started occurring around the 18th May. Could it be related to this G.INP business? Should I update the firmware right now?
Community Veteran
Posts: 6,651
Thanks: 230
Fixes: 16
Registered: 16-02-2009

Re: TP-Link TD-W9980 modem/router DNS server not working

G.INP will not affect you logging in. It is purely a speed problem.
I would update the f/w anyway as if you are on a G.INP cabinet then your speed will be ~10Mb down.
But check the logs, re-input your username/password and check the logs again. It will usually say something like invalid password from ppp.
bbslaw
Newbie
Posts: 6
Registered: 27-05-2015

Re: TP-Link TD-W9980 modem/router DNS server not working

So, as you suspected, it was the password that had changed.  Embarrassed
It's all working now fine. Thing is, I'm sure I never changed the password on the DSL, only on the account, and I'm sure the time separation between doing so and the internet going down was at least a couple of weeks. So not really sure why it happened when it did. Hey ho.
Thanks for all your help.
Moderator
Moderator
Posts: 17,532
Thanks: 1,080
Fixes: 126
Registered: 11-01-2008

Re: TP-Link TD-W9980 modem/router DNS server not working

they're the same password though and it probably didn't go down earlier as you already had a connection established and until that dropped it wouldn't need to authenticate again.
Will Moderate For Thanks