cancel
Showing results for 
Search instead for 
Did you mean: 

TG582n forgets port forwarding setting

guinness
Newbie
Posts: 3
Registered: 11-04-2015

TG582n forgets port forwarding setting

I have my TG582n router (software 10.2.5.2.FO) set up to open and forward port 32400 in order to access my Plex Media Server externally.
When the forwarding is initially set up, this works perfectly however within 1-2 days, the router seems to "forget" the setting and Plex becomes inaccessible externally, although the settings in the admin interface stay put and look fine.  A restart of the router and it all starts working fine again for a day or so, then the cycle starts again Sad
Can anyone help with a solution to this? It's very frustrating as I inevitably discover it has happened when I am away from home and am not able to restart the router.
Thanks in advance
4 REPLIES
Community Veteran
Posts: 1,841
Thanks: 103
Fixes: 6
Registered: 21-01-2013

Re: TG582n forgets port forwarding setting

Is the media server on a static IP address?
If so change it to a dynamic IP address, one assigned by DHCP, and in the routers network settings for that device place a tick in the box "always use the same IP address".
guinness
Newbie
Posts: 3
Registered: 11-04-2015

Re: TG582n forgets port forwarding setting

Thanks for the reply.  Yes, the media server is already on a "static IP", but only by way of being on DHCP with the "always use the same IP" option ticked (infinite lease).  At the server end, it's configured as DHCP too.
I have other machines mounting the server's drives by specific IP so I'm fairly confident the IP hasn't changed in a long while.
Community Veteran
Posts: 1,841
Thanks: 103
Fixes: 6
Registered: 21-01-2013

Re: TG582n forgets port forwarding setting

Could it be the Plex is going to sleep mode while you're away?
Or the router could be losing the Plex ARP listing if it's inactive for long periods.
You could try creating a static entry for the Plex in the routers ARP table.
See: http://npr.me.uk/wol.html
Or do you need the full Wake on LAN from Internet.
guinness
Newbie
Posts: 3
Registered: 11-04-2015

Re: TG582n forgets port forwarding setting

WoL from the internet would be a nice to have, although the server runs 24/7 anyway so i'm not sure how much I'd use it.
I don't think the server is going to sleep because I am able to recreate this scenario easily using the Plex mobile (android) client.  By enabling WiFi on my phone (therefore joining my LAN) I can connect to  the Plex server no problem.  If I switch off WiFi and revert to an external connection via HSDPA, I can no longer connect until the router has been restarted, however switching back to WiFi is instantly fine without a router restart.