cancel
Showing results for 
Search instead for 
Did you mean: 

Speed test shows all is fine but http browsing very slow

candell
Grafter
Posts: 28
Registered: ‎18-02-2014

Speed test shows all is fine but http browsing very slow

Hi all

 

Browsing of web pages is incredibly slow, tethering to my phone is so much faster despite speed tests showing much slower results for the phone.

 

The fibre line is showing as 31/8 and my phone (in the house) is 6/1.

 

ftp is going well, just webpage browsing that is taking an age to load up any page.

 

Also, apps such as facebook and instagram on the phone show placeholders as the images just don't load. Turn off wifi to use phone data and they all appear in the blink of an eye.

I contact plusnet support and they say that everything is working well, can anyone suggest next steps?

Thanks

6 REPLIES
rongtw
Seasoned Hero
Posts: 6,973
Thanks: 1,533
Fixes: 12
Registered: ‎01-12-2010

Re: Speed test shows all is fine but http browsing very slow

Are you connected Via WIFI ?  or wired  

have you checked what is connected to your Router ?

then have you run a AV check or malwarebytes ?

Asus ROG Hero Vii Z97 , Intel i5 4690k ,ROG Asus Strix 1070,
samsung 850evo 250gig , WD black 2 TB . Asus Phoebus sound ,
16 gig Avexir ram 2400 , water cooling Corsair H100i gtx ,
Corsair 750HXI Psu , Phanteks Enthoo pro case .
Plusnet Help Team
Plusnet Help Team
Posts: 383
Thanks: 81
Fixes: 10
Registered: ‎07-12-2017

Re: Speed test shows all is fine but http browsing very slow

Hi there Smiley

 

Testing your line isn't finding the cause of the issue. It could be a Wireless issue, try using a device via an Ethernet cable, if you are having the same problem please let us know.

If this post resolved your issue please click the 'This fixed my problem' button
 Lauren Barry
 Plusnet Help Team
candell
Grafter
Posts: 28
Registered: ‎18-02-2014

Re: Speed test shows all is fine but http browsing very slow

Using wifi most of the time however wired makes no difference. Initially believed that it may be the old BBHH3 I was using so swapped out for a brand new router, same issue both wired and wifi.

 

No malware or viruses on any device

gofaster
Rising Star
Posts: 367
Thanks: 12
Registered: ‎01-08-2007

Re: Speed test shows all is fine but http browsing very slow

I find the Plusnet Domain Name Servers can be a bit slow.

You could try switching over to the Google public DNS to see if this helps - IP addresses are 8.8.8.8 and 8.8.4.4

This web page might help you to configure them

https://developers.google.com/speed/public-dns/docs/using

 

 

candell
Grafter
Posts: 28
Registered: ‎18-02-2014

Re: Speed test shows all is fine but http browsing very slow

Thanks for the DNS recommendation. I have done this and immediately it seems to be working great however the browsing issues were up and down so will continue to monitor.

Plusnet Help Team
Plusnet Help Team
Posts: 9,522
Thanks: 3,070
Fixes: 482
Registered: ‎21-04-2017

Re: Speed test shows all is fine but http browsing very slow

I'm glad to hear your connection is better now.

Please let us know if you do still experience issues.

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team