cancel
Showing results for 
Search instead for 
Did you mean: 

Speed not what it should be and web browsing is slow and keeps buffering

sevanseta
Newbie
Posts: 3
Registered: 03-04-2015

Speed not what it should be and web browsing is slow and keeps buffering

Hi,
I've had Plusnet 38mb fibre installed for 11 days now.  When I signed up I was told I should receive around 35mb, but I've been running speed tests since day 1 and the max I've ever got is up to 30mb with around 10mb upload speed. My ping was 7ms. Why am I not receiving up to 35mb? My router is a TP-Link WR841N. I tested this with a wired connection.
My next question which is more of an issue is that for the last few days my fibre broadband has been disconnecting a couple of times each day and browsing the web is sometimes very laggy, with pages not being loaded properly. I did a speed test just now (please see image below) and I can see that the connection is not a strong as it was at the beginning when I first started using Plusnet, especially the ping which has risen to 14ms.  I did this speed test several times and this was the best speed out of all the tests that I did just now. All tested with the ethernet cable.

Please could you do a line check or something to help and see what could be causing the problems?
Thanks.
2 REPLIES
Plusnet Help Team
Plusnet Help Team
Posts: 5,056
Thanks: 445
Fixes: 161
Registered: 01-01-2012

Re: Speed not what it should be and web browsing is slow and keeps buffering

Sorry to hear your seeing issues.
We saw a couple of drops on Thursday as shown in the graph below but no others

With regards to the ping even at the current level of 14ms that's still very good.
The sync is only 5mbps below the original estimate so there is a chance that might be as good as it gets but if you want us to investigate further raise a fault using the link below
https://faults.plus.net
If this post resolved your issue please click the 'This fixed my problem' button
 Matthew Wheeler
 Plusnet Help Team
Jhchicks
Dabbler
Posts: 14
Thanks: 1
Registered: 10-01-2015

Re: Speed not what it should be and web browsing is slow and keeps buffering

Lucky you, I get 20meg down and under 7 meg upload! I'm on upto 38meg 19.5 upload.
And yes my browsing is s-l-o-w! It even locks up requiring a full re-boot.
JH