cancel
Showing results for 
Search instead for 
Did you mean: 

Speed issues and odd connection problem

bigcal27
Newbie
Posts: 6
Registered: 23-04-2015

Speed issues and odd connection problem

Just had Fibre installed, and it's mostly going great so far. Connected at 40mb, which is the package I paid for so that's all fine. I can download at 4mb/s as my speed suggests... except when I download through Usenet. I seem to only be able to get 1.5mb/s at best. I first tried changing some settings in my download client, then contacted my Usenet provider for help, and it all seems to be fine on those fronts so I'm guessing it's something with Plusnet.
Also, for some reason I am having problems connecting to Steam. If I'm downloading, Steam will NOT connected at all. If I pause a download, Steam connects. Unpause it, Steam disconnects. Any ideas why this is happening too?
5 REPLIES
bigcal27
Newbie
Posts: 6
Registered: 23-04-2015

Re: Speed issues and odd connection problem

Anyone able to help? Smiley
Plusnet Help Team
Plusnet Help Team
Posts: 1,953
Thanks: 22
Fixes: 5
Registered: 24-07-2014

Re: Speed issues and odd connection problem

I've posted in your other thread about this, but if you could give details of your Usenet provider and settings we can take a further look.
If this post resolved your issue please click the 'This fixed my problem' button
 Tony T
 Plusnet Help Team
bigcal27
Newbie
Posts: 6
Registered: 23-04-2015

Re: Speed issues and odd connection problem

Usenet provider is Newsdemon. Already contacted them first to see if the problem was on their end and they claim that they don't limit speeds. My friend, who lives on the same street and also has fibre, just with BT, also uses them and has the same setup as me with no problems.
I use their europe-ssl.newsdemon.com host and port 563 with SSL enabled. I have tried all of their ports and hosts, both SSL and non SSL and seen no changes.
If you need any more info just let me know.
Thanks.
aaaron
Newbie
Posts: 4
Registered: 27-04-2015

Re: Speed issues and odd connection problem

bigcal27:
I'm in a similar position, just had fibre installed and get the line speed for HTTP traffic. I get 1mB with P2P traffic. This cannot be coincidental and is certainly not the deal I signed up for. It's strange how it's not just me who is limited to such ridiculous speeds, but yourself and at least one other has posted recently regarding this.
Plusnet state on this page:
http://www.plus.net/support/broadband/speed_guide/traffic_management.shtml
"We do not apply rate limits to any of our current residential or business products."
Surely that is exactly what is in operation for P2P traffic?
Plusnet Help Team
Plusnet Help Team
Posts: 1,953
Thanks: 22
Fixes: 5
Registered: 24-07-2014

Re: Speed issues and odd connection problem

I was going to try to replicate it, but I don't know anyone on that server. I will however see what further tests can be done for you.
If this post resolved your issue please click the 'This fixed my problem' button
 Tony T
 Plusnet Help Team