cancel
Showing results for 
Search instead for 
Did you mean: 

Slow web browsing

nickbaker57
Newbie
Posts: 2
Registered: ‎17-10-2016

Slow web browsing

For about 2 weeks now I have been having terrible problems browsing the internet. It takes ages for pages to load and I nearly always get an error page saying `This site can't be reached' the site took too long to respond - ERROR_CONNECTION_TIMED_OUT  Reload

This happens on all my devices - PC, laptop, ipad, iphone etc.

I have checked the connection and that is fine - speed tests show there is nothing wrong with the connection and Netflix works fine etc. I Googled the problem and other people are clearly having the same problem but it all started getting a bit technical talking about gateways and changes of network.

Can anybody help me sort this out as it is driving me nuts - plus my wife keeps going crazy when she's trying to shop online and the web page won't load and she has to start all over again.

Any advice would be very welcome

Thanks

3 REPLIES
rongtw
Seasoned Hero
Posts: 6,973
Thanks: 1,532
Fixes: 12
Registered: ‎01-12-2010

Re: Slow web browsing

Have you checked your Firewall settings in Member Center ? https://www.plus.net/help/broadband/about-plusnets-broadband-firewall/

also check if the PN safeguard  is OFF  https://www.plus.net/help/broadband/how-to-use-plusnet-safeguard/

Asus ROG Hero Vii Z97 , Intel i5 4690k ,ROG Asus Strix 1070,
samsung 850evo 250gig , WD black 2 TB . Asus Phoebus sound ,
16 gig Avexir ram 2400 , water cooling Corsair H100i gtx ,
Corsair 750HXI Psu , Phanteks Enthoo pro case .
Community Gaffer
Community Gaffer
Posts: 17,674
Thanks: 661
Fixes: 165
Registered: ‎05-04-2007

Re: Slow web browsing

Is this wired or wireless connections? Is Netflix on the same device you're having these issues on?

If this post resolved your issue please click the 'This fixed my problem' button
 Chris Parr
 Plusnet Staff
nickbaker57
Newbie
Posts: 2
Registered: ‎17-10-2016

Re: Slow web browsing

Thanks for your replies. I have a wireless network (although my PC connects directly to the router with ethernet cable) which seems to work fine for all my family's devices including streaming netflix to the TV. I find it hard to believe that a firewall setting or something like that would be the cause - why would all our devices have the same browsing problems? I forgot to mention I also use Plex media server which is installed on my PC and streams movies perfectly to my TV and ipad etc. over the wi-fi network. As I mentioned above - download speeds are fine it is just the loading of web pages that seems to be an issue. I'm not very technical but could it have anything to do with the way web pages are cached on the plus.net servers? I have checked my account and I have the Plusnet Safeguard turned off if that makes any difference.

Thanks again for your replies

Nick