cancel
Showing results for 
Search instead for 
Did you mean: 

Slow page loads

FIXED
andun84
Rising Star
Posts: 231
Thanks: 2
Fixes: 1
Registered: ‎01-08-2007

Slow page loads

My normal modem/router stopped working yesterday, Asus DSL-AC68U, and I switched to the Plusnet SmartHub 2. Whilst the sync speed is better, as I expected as the modem in the Asus is well known to be poor, however page loads are dreadful. If I click on a page that isn't cached it will take forever with resolving host in the bottom corner of the browser before it loads. A speedtest says the ping is 29ms which is about normal for me yet the slowness is really bad. The page will eventual load then it will think about loading the images. I've changed DNS servers on both the SmartHub 2 and at the connection to CloudFlare, Google & Open DNS. All experience exactly the same slowness. I was not experiencing these issues before I had to swap yesterday.

If I switch on my VPN, ExpressVPN, then the pages load almost instantly.

I'm so lost as to what it could be if it is not DNS given ExpressVPN doesn't have the same problem.

I'm lost here. Just for info I am on Linux. That's not because I the Linux is the issue, which I don't, but just in case wants to start giving me Windows tips Smiley 

2 REPLIES 2
andun84
Rising Star
Posts: 231
Thanks: 2
Fixes: 1
Registered: ‎01-08-2007

Re: Slow page loads

Fix

All seems to be working great this evening. Everything loading really quickly. Let's hope that it sticks Smiley 

LaurenB
Plusnet Help Team
Plusnet Help Team
Posts: 2,503
Thanks: 499
Fixes: 125
Registered: ‎07-12-2017

Re: Slow page loads

Hiya @andun84, thanks for getting in touch. I'm really sorry to hear of the problems that you have experienced with the router, though pleased everything seems to now be working OK.

 

Should you have any further queries at all, please do just get back to us Smiley

If this post resolved your issue please click the 'This fixed my problem' button
 Lauren Barry
 Plusnet Help Team