cancel
Showing results for 
Search instead for 
Did you mean: 

Slow or failing external connections, can someone help?

ihavenoidea
Dabbler
Posts: 12
Registered: 18-01-2013

Slow or failing external connections, can someone help?

I have recently noticed an issue with my home network, I believe either Plusnet is blocking the connections or there is a fault somewhere along the line but I can't figure out what.

 

Setup:

- Fibre broadband (80/20, but really more like 70/17),

- BT Openreach modem that I've had since the day I signed up to Plusnet 4 years ago

- Asus AC87U Router (all the necessary ports have been forwarded to allow access)

- Three unmanaged PoE switches, all connecting back directly to the router.

- All hardware are connected using CAT5e cable

- 2x NAS systems

- 4x IP Cameras

 

Issue:

So for a number of years now I have connected remotely to my home NAS systems to stream my music/video libraries via SFTP and this has worked fine. Recently I have noticed that the initial connection to the servers back at home take extremely long to connect (30-60 seconds), once connected any CRUD (create, read, update, delete) actions also take a considerable amount of time. What's interesting is that I could be using my phone's cellular network to connect and experience the issues, however as soon as I get into work and use their WIFI, the connection is fine again. Even more strange is that it doesn't seem to be limited to particular IP's or ISP's as the next day my phone cellular network may work fine but my workplace ISP will experience the slow connections speeds.

 

 

Steps to Troubleshoot:

Now one may think maybe this is a problem with the NAS itself or the connection to the router, however I have tried connecting to my other NAS box (I have two) and this also experiences the same issue. The second NAS box unlike the first, has a direct connection to my router.

 

I thought maybe this is an issue with the SFTP protocol, so I have tested connecting to my IP Camera's using RTSP and also experience the same intermittent connection issues.

I have disabled all built firewall and DDOS features on my router but this appears to have no affect. 

 

I believe there is some sort of blocking going on at the ISP level, as I had issues with my upload speed a few months back (and required 4 engineer call outs to fix it!). I've tried to speak to Plusnet about the issue but they have simply dismissed this as a problem with my internal configuration and stated connections inbound are out of scope of their tech support.