cancel
Showing results for 
Search instead for 
Did you mean: 

Slow Speeds Since Purchase

JakeB52
Newbie
Posts: 3
Registered: 06-05-2017

Slow Speeds Since Purchase

Hi,

since I have had my fibre installed (Roughly a year) I have not achieved the full speeds advertised and in fact no where near. On top of that, my download will consitantly sit below 1 mb/ps. I purchased this internet package for reliability and speed second. I don't have the reliability or speed that is advertised. I can't even play the simplest of games due to connection or stream things from YouTube as they buffer stutter or fail to load. 

I would use the online chat but it isn't available so I have resorted to this. I know no one who is having a good experience with Plusnet and especially their fibre which is becoming a staple of the consumer. If they can't get this right, I may as well move providers, AGAIN. 

File attached is the best speeds I have had in a longtime. That is with everything that uses bandwidth closed and as much shut down as possible, including other devices. Again, those are ridiculous speeds for fibre optic, especially the top package. 

5 REPLIES
rongtw
Seasoned Hero
Posts: 6,973
Thanks: 1,531
Fixes: 12
Registered: 01-12-2010

Re: Slow Speeds Since Purchase

what were you told  you should get ?   and what does it say here ? https://www.dslchecker.bt.com/

also are you testing wifi or wired

Asus ROG Hero Vii Z97 , Intel i5 4690k ,ROG Asus Strix 1070,
samsung 850evo 250gig , WD black 2 TB . Asus Phoebus sound ,
16 gig Avexir ram 2400 , water cooling Corsair H100i gtx ,
Corsair 750HXI Psu , Phanteks Enthoo pro case .
Browni
Aspiring Hero
Posts: 2,280
Thanks: 775
Fixes: 45
Registered: 02-03-2016

Re: Slow Speeds Since Purchase

I noticed that you said you would move providers "AGAIN", did this problem exist with your previous provider and you were hoping the move to Plusnet would fix it?
I must have been really bad in a previous life as this was my 3rd ISP in a row that used lithium.
Now you're stuck with me because my new ISP doesn't run a forum Cheesy
JakeB52
Newbie
Posts: 3
Registered: 06-05-2017

Re: Slow Speeds Since Purchase

Hi, I moved providers originally from BT to Plusnet in hopes of more reliability. BT's speeds were always above 70 up and 20 down which is perfect for me, but, they had a lot of downtime in my area so I was left with nothing rather than slow internet. Once I moved to Plusnet, I had an initial couple days of great speeds and low ping but since then I have had nothing but ridiculously slow speeds which is putting me in the position to move provider again. 

Short answer, I moved from good speeds but a fair bit of downtime to terrible majorly sub-par speeds and also, again, downtime. 

Attachment: I used Steam to demonstrate what I get currently, no matter what I do. With BT and for a VERY short period after having Plusnet installed I was reaching around 12.5 mb/ps on Steam and now I am below 1 mb/ps.

Cheers for the reply.

JakeB52
Newbie
Posts: 3
Registered: 06-05-2017

Re: Slow Speeds Since Purchase

I was told I would get up to 76 mb/ps as advertised online. Obviously I expected a little leeway whether that be up or down, but to be getting only 5 up and 5 down is ludicrous and a joke. 

I am testing wired, currently have my PC connected to the router directly by ethernet. I have also tested many other devices this way and still get the same results. 

Community Veteran
Posts: 1,549
Thanks: 260
Fixes: 33
Registered: 13-08-2015

Re: Slow Speeds Since Purchase

Are you able to log into the router and post the details from the Helpdesk tab in the advanced section, making sure you hide any personal details such as your username?