cancel
Showing results for 
Search instead for 
Did you mean: 

Router can not see devices connected through WI-FI extender?

AdrianPH
Dabbler
Posts: 22
Registered: 31-05-2014

Router can not see devices connected through WI-FI extender?

I have been struggling with this for a while well almost a week since I went on to  Fibre from ADSL.
I have several things in my room connected via a network extender an Edimax NV300 or CV7428ns universal Wi-Fi bridge.  Things like a NAS, Network printer, my own PC and an asterisk server.
Problem is the Plusnet/Sagen 2704 does not recognise any devices on the Wi-Fi bridge, all I ever get is the mac address of the Edimax and an unknown device name.
Problem is the previous router TG582n could recognise all devices on the bridge.
I have looked through the expert_user pages and nothing comes to mind that would help.
I also note that sometimes the 2704 looses device names to devices even connected to the wired ports, so have changed the lease time down to 6 hours to try and alleviate the issue.
Can anyone shed any light as to what I can do regards the Wi-Fi bride devices and what could be causing the 2704 to loose the device names?
In hope someone can help solve this.
Adrian
11 REPLIES
Andrue
Pro
Posts: 775
Thanks: 90
Fixes: 1
Registered: 12-01-2015

Re: Router can not see devices connected through WI-FI extender?

Is everything definitely on the same subnet?
AdrianPH
Dabbler
Posts: 22
Registered: 31-05-2014

Re: Router can not see devices connected through WI-FI extender?

Yes all on the same subnet, I use the 2704 as a DHCP server.  My PC gets it's IP from the 2704 and can connect to the internet but it's device name is not present on the 2704, so no other computer can find it, I have made the printer static IP, and I now print to the IP address:portnumber to print, but things like NAS and SIP phone are still dynamic.
Adrian
AdrianPH
Dabbler
Posts: 22
Registered: 31-05-2014

Re: Router can not see devices connected through WI-FI extender?

Thought if I could add a picture it may help show what I mean.
In the device list the unknown is the mac address of my Wi-Fi bridge, but the IP address is that of the SIP phone.
My PC I am on has IP address of 192.168.1.5 is not shown and neither is the NAS.
Adrian
Could I go back to using the older router perhaps with a firmware update to work in bridge mode or something so I can re-use that with fibre?
Superuser
Superuser
Posts: 6,778
Thanks: 858
Fixes: 55
Registered: 30-07-2007

Re: Router can not see devices connected through WI-FI extender?

You can flash the TG582 with firmware that allows LAN port 4 to be used as a wan port.
The latest one is 10.2.5.2.FO here http://products.plus-payh.co.uk/firmware/ .
AdrianPH
Dabbler
Posts: 22
Registered: 31-05-2014

Re: Router can not see devices connected through WI-FI extender?

My old router is a non usb type, probably a few years old does that matter as all the firmwares seem to be with USB?
Adrian
Superuser
Superuser
Posts: 6,778
Thanks: 858
Fixes: 55
Registered: 30-07-2007

Re: Router can not see devices connected through WI-FI extender?

From my experience it doesn't matter whether the router had a USB port or not, the later f/w will work. I think they all had the USB chip , just some didn't have the physical port.
AdrianPH
Dabbler
Posts: 22
Registered: 31-05-2014

Re: Router can not see devices connected through WI-FI extender?

Sorry for the delay in replying but the upgrade worked, I do not seem to be loosing devices from the list any more, so at least I have two routers I can now use. One device is stubbenly not passing it's name through to the router so will work on that either replace or move to an actual wired port.
Thanks for the help.
Adrian
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Router can not see devices connected through WI-FI extender?

If you log into the 2704n using http://192.168.1.254/expert_user.html you should see all devices listed on the relevant pages. There seems to be some sort of bug where not all devices get shown at all times on the My Home Network page Sad
AdrianPH
Dabbler
Posts: 22
Registered: 31-05-2014

Re: Router can not see devices connected through WI-FI extender?

Well I will keep eyes open for a firmware update, because my asterisk server has not lost it's lease or disappeared from the list with the 582 Router, so not a lot of point going back to the 2704 yet.
Adrian
Community Veteran
Posts: 19,101
Thanks: 443
Fixes: 21
Registered: 31-08-2007

Re: Router can not see devices connected through WI-FI extender?

What software version have you got on the 2704n. If you have the first version, stick with it. v2 is no help whatsoever to those issues.
AdrianPH
Dabbler
Posts: 22
Registered: 31-05-2014

Re: Router can not see devices connected through WI-FI extender?

Pass on the software for the 2704 not plugged in at the moment, but the thing was only plugged in on the 5th October and had only arrived a few days before so should be the latest code.
Adrian