cancel
Showing results for 
Search instead for 
Did you mean: 

Port 21 not stealthed

MartyPop
Rising Star
Posts: 137
Thanks: 13
Registered: 01-10-2014

Port 21 not stealthed

After doing a Shields-Up test on my one-week old TG582n, everything appears to be OK apart from port 21 (see attached screenshot).
How do I stealth port 21?
21 REPLIES
Superuser
Superuser
Posts: 11,896
Thanks: 3,260
Fixes: 22
Registered: 22-08-2007

Re: Port 21 not stealthed

Use the PlusNET firewall.
Log into the portal, select connection settings and then the firewall option.
Community Veteran
Posts: 1,841
Thanks: 103
Fixes: 6
Registered: 21-01-2013

Re: Port 21 not stealthed

Disable the "FTP server" in the routers "content sharing".
Community Veteran
Posts: 38,460
Thanks: 1,027
Fixes: 62
Registered: 15-06-2007

Re: Port 21 not stealthed

can you be a bit more explicit as I can't see that option
Community Veteran
Posts: 1,841
Thanks: 103
Fixes: 6
Registered: 21-01-2013

Re: Port 21 not stealthed

I'm not using a TG582n at present so I'm going from memory:
Go to Home > Toolbox > Content Sharing  > configure:
Somewhere on that page there's a tick box to enable the routers FTP server -- remove the tick.
IF you can't find the setting, let me know and I'll plug in my tg582 and hopefully give better guidelines.
Community Veteran
Posts: 38,460
Thanks: 1,027
Fixes: 62
Registered: 15-06-2007

Re: Port 21 not stealthed

I wonder if that comes with updated firmware as mine shows and I am on 8.4.4.J but not fibre obviously
Community Veteran
Posts: 1,841
Thanks: 103
Fixes: 6
Registered: 21-01-2013

Re: Port 21 not stealthed

That GUI setting may not be present in routers without the USB port (the ones supplied for ADSL)
I haven't had one of those router to check.
If there's no USB port there's no use for a FTP server but that's no guarantee that Technicolor would disable the server.
IIRC the setting is present in older firmware version of Plusnet fibre routers.
DaveyH
Seasoned Pro
Posts: 1,429
Thanks: 246
Fixes: 9
Registered: 15-11-2012

Re: Port 21 not stealthed

The port is closed, so does it really matter?
MartyPop
Rising Star
Posts: 137
Thanks: 13
Registered: 01-10-2014

Re: Port 21 not stealthed

Quote from: npr
Disable the "FTP server" in the routers "content sharing".

Thanks but it's already disabled (by default).
MartyPop
Rising Star
Posts: 137
Thanks: 13
Registered: 01-10-2014

Re: Port 21 not stealthed

Quote from: Oldjim
I wonder if that comes with updated firmware as mine shows and I am on 8.4.4.J but not fibre obviously

I don't seem to be able to find the firmware revision but I can find the software version (10.2.5.2.FO)
MartyPop
Rising Star
Posts: 137
Thanks: 13
Registered: 01-10-2014

Re: Port 21 not stealthed

Quote from: Townman
Use the PlusNET firewall.
Log into the portal, select connection settings and then the firewall option.

OK, done that, thanks:
With the setting at "Low", things were worse than with the firewall set to "Off"
With the setting at "High", all common ports are now stealthed (inc. port 21)
I'll leave it set at "High" for a while and see if I have any problems  Smiley
MartyPop
Rising Star
Posts: 137
Thanks: 13
Registered: 01-10-2014

Re: Port 21 not stealthed

Quote from: DaveyH
The port is closed, so does it really matter?

Yes, it does matter (to me).
Community Veteran
Posts: 3,274
Thanks: 339
Fixes: 12
Registered: 24-10-2013

Re: Port 21 not stealthed

can you explain why it matters ?
MartyPop
Rising Star
Posts: 137
Thanks: 13
Registered: 01-10-2014

Re: Port 21 not stealthed

Yes, indeed I can  Smiley
It's simply a matter of "The less that people see, the better"
Community Veteran
Posts: 3,274
Thanks: 339
Fixes: 12
Registered: 24-10-2013

Re: Port 21 not stealthed

ah so it's tin foil hat stuff then rather than anything else.