cancel
Showing results for 
Search instead for 
Did you mean: 

Poor Fibre Extra speeds

Highlighted
Dabbler
Posts: 20
Thanks: 3
Registered: ‎26-11-2016

Poor Fibre Extra speeds

Hi Guys,

I took advantage of your recent upgrade to 'Extra' offer a few weeks ago, switch over was the 10th September, but I'm seeing really poor speeds. Indeed download is actually slower than it was on standard fibre.

I use a live speed monitor on my Mac, and can see constantly what speeds I'm getting, I used to see steady speeds of 37Mbps downstream on standard fibre. On Extra I rarely see anything above 30Mbps. Occasionally it peaks at 50Mbps downstream for a few seconds, and does sometimes hit 20Mbps on upstream, but in the main they're very much in the 10-12mbps upstream and 20-30mbps downstream.

I've attached a screen shot of the BT speed test, which confirms the poor speeds.

I'm connected on Ethernet, and using a Hub One.

Cheers.

Andy
3 REPLIES 3
Highlighted
Plusnet Help Team
Plusnet Help Team
Posts: 1,327
Thanks: 234
Fixes: 52
Registered: ‎07-12-2017

Re: Poor Fibre Extra speeds

Hi @Wildroverandy, I'm sorry for the issues you're having.

 

I have tested the line and we're seeing you in sync at 76.3mb and no faults have been detected; I've also had a check and there's no signs of congestion.

 

Can you please get your router connected to the test socket and raise a fault to us here letting us know when you've done it so we can pick it up and investigate further.

If this post resolved your issue please click the 'This fixed my problem' button
 Lauren Barry
 Plusnet Help Team
Highlighted
Dabbler
Posts: 20
Thanks: 3
Registered: ‎26-11-2016

Re: Poor Fibre Extra speeds

Thanks for your reply Lauren,

I can't get onto doing that for a while, the connection box is not in a convenient location, and being as we're in a let house, cannot start unscrewing bits from the wall all that easily.

However, I have a development. I switched to using WiFi on my iMac, which connects using the 'ac' protocol at a decent speed, and I now seem to have good broadband speeds again - steady at 64Mbps downstream, and up to 19Mbps upstream.

Looks like it might be an Ethernet issue somewhere. I'm using Homeplugs, so I guess I'll have to investigate more on that side for now.

The BT speed tester isn't much help it seems, even though I'm seeing better speeds displayed on my local machine, the BT tester is still showing poor speeds. Is there a preferred browser to use for that? I initially used Firefox, and tried again with Safari, but they both show the same (don't ask me to install Chrome, nothing Google gets installed on my system).

Regards

Andy.

Andy
Highlighted
Plusnet Help Team
Plusnet Help Team
Posts: 1,631
Thanks: 273
Fixes: 57
Registered: ‎26-03-2018

Re: Poor Fibre Extra speeds

Hi @Wildroverandy 

 

Thanks for letting us know that things are on the up. 

 

Please do let us know how your Homeplug investigation goes, and if you get round to doing the checks that were provided above. 

In regards to the speed tester -  Edge/Explorer has given me the most accurate results at home personally, and I don't normally hold them in much regard as browsers in of themselves, but that's just me I guess. 

 

Kind Regards, 

MoR

If this post resolved your issue please click the 'This fixed my problem' button
 MoR
 Plusnet Help Team